Hitachi Vantara Pentaho Community Forums
Results 1 to 10 of 10

Thread: Bugzilla DashBoard failing to import data

  1. #1
    Join Date
    Dec 2007
    Posts
    13

    Default Bugzilla DashBoard failing to import data

    Here goes.
    Here is my settings:
    VM running bugzilla and mysql on linux.
    created the software_qa_rpt database in the same instance as bugzilla's database with a different user.
    I am running the Jboss demo within Windows 2000.

    I know this works I was able to run the sample reports against the sample data in the software_qa_rpt database.

    yet, when I run LOAD - Bugzilla I get connection errors.
    Here are my settings.
    <code>
    From database3-ds.xml
    from pentaho-solutions/system/kettle.properties
    I am getting the following error with in the Jboss server.log
    I did not know you could attach files so here they are.....

    Any insight would be helpful.
    Have a great holiday season.
    Attached Files Attached Files

  2. #2
    Join Date
    Dec 2007
    Posts
    13

    Default

    BTW, the Jboss Instance is using the mysql-connector-java-5.0.7-bin.jar

  3. #3
    Join Date
    May 2006
    Posts
    4,882

    Default

    "Connection refused: connect" ... wrong ip address, firewal, ... try connection yourself outside of kettle to the database.

    Regards,
    Sven

  4. #4
    Join Date
    Dec 2007
    Posts
    13

    Default

    Am able to connect to both databases on the same instance within the VM from my windows box via command line as well as a simple Java class utilizing JDBC.

  5. #5
    Join Date
    May 2006
    Posts
    4,882

    Default

    Well... your log files says that Kettle can't connect. Make a very small transformation that selects e.g. some rows and run that on the same server where the app server is running.

    Regards,
    Sven

  6. #6
    Join Date
    Dec 2007
    Posts
    13

    Default

    Quote Originally Posted by sboden View Post
    Well... your log files says that Kettle can't connect. Make a very small transformation that selects e.g. some rows and run that on the same server where the app server is running.

    Regards,
    Sven
    Now you've lost me.
    To fill you in, I am new to pentaho and its reporting engine and such.
    I'm not against learning, just point me in the right direction and I will setup tests to figure this out. Yet, please give me as much detail as possible.


    BTW, thanks for replying.

  7. #7
    Join Date
    May 2006
    Posts
    4,882

    Default

    Kettle can't connect to the databases... that's for sure. Wrong IP addresses, userids, passwords, firewalls, ...

    You can connect to the databases outside of Kettle.

    So
    Run something small on the server on which kettle run (the app server machine) to connect to the database, preferably something not-kettle. If that works you've ruled out firewall problems. If that doesn't work you have to look at connectivity between server and database.

    If that non-kettle things can connect, but kettle still doesn't you probably have an error in IP address/userid/password in the connection in Kettle.

    Regards,
    Sven

  8. #8
    Join Date
    Dec 2007
    Posts
    13

    Default

    Ok, I see what you are saying.
    Yet I was able to run the sample reports from within Pentaho that utilizes the connection information contained within the database3-ds.xml
    With no errors.
    It just seem to be within the Kittle as you stated.

    Now, what the heck is a Kittle?

    Again, thank you for your input and assistance with this.

    Quote Originally Posted by sboden View Post
    Kettle can't connect to the databases... that's for sure. Wrong IP addresses, userids, passwords, firewalls, ...

    You can connect to the databases outside of Kettle.

    So
    Run something small on the server on which kettle run (the app server machine) to connect to the database, preferably something not-kettle. If that works you've ruled out firewall problems. If that doesn't work you have to look at connectivity between server and database.

    If that non-kettle things can connect, but kettle still doesn't you probably have an error in IP address/userid/password in the connection in Kettle.

    Regards,
    Sven

  9. #9
    Join Date
    Dec 2007
    Posts
    13

    Default

    I double checking something after trying to run one of the report which resulted in a classNotFound Exception.
    If you look within the attached (other replys) datasource3-ds.xml it is referencing a driver-class of org.mysql.jdbc.Driver</driver-class>

    yet after looking into the documentation which states to use com, not org..
    This is my mistake.

    Yet still getting the connection refused exception...

    Still digging.

  10. #10
    Join Date
    Dec 2007
    Posts
    13

    Default

    Ok--Yes I got it working again..
    Had to move the kittle.properties to the system\.kittle\

    it is now working ...

    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.