Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Imagenes dinamicas en reports

  1. #1
    Join Date
    May 2007
    Posts
    10

    Default Imagenes dinamicas en reports

    Buenos d�*as.

    Estoy intentando crear unos informes que deben coger un logo dependiendo de un parámetro, por lo que estoy intentando utilizar los campos image field e image url field.
    Con image field estoy teniendo problemas con los tipos de oracle. Me da la excepcion Could not fetch data. Continue? Reason: oracle.sql.blob.
    He probado con los tipos bloc, clob, bfile y long raw, siempre con la misma excepción. Sin embargo, con mysql funciona sin problemas.

    En cuanto a los campos image url field no sé si tengo que poner rutas relativas a partir de un punto o direcciones de internet. He probado varias y rutas absolutas pero no se me muestra la imagen.

    ¿Alguien ha realizado algo similar que pueda orientarme con la solución?

    Muchas gracias.

  2. #2
    Join Date
    May 2007
    Posts
    10

    Default

    Estoy intentando probar con image URL field pero estoy obteniendo el error:

    Error while loading the image from 'http://localhost:8080/pentaho/img/logo.jpg': Failed to load the image. ImageObserver signaled an error.

    Si pongo esa url en un navegador puedo ver la imagen sin problemas.

    Muchas gracias.



  3. #3

    Default

    Buen día jamoreno me podrías explicar por favor como haces para enviar los parámetros de la imagen y te cargue en el formulario, y si llevas los parametros por la url como los mandas y en que orden.
    Muchas gracias

  4. #4
    Join Date
    Apr 2009
    Posts
    11

    Default

    Quote Originally Posted by jamoreno View Post
    Estoy intentando probar con image URL field pero estoy obteniendo el error:

    Error while loading the image from 'http://localhost:8080/pentaho/img/logo.jpg': Failed to load the image. ImageObserver signaled an error.

    Si pongo esa url en un navegador puedo ver la imagen sin problemas.

    Muchas gracias.



    Hola,


    Hace un tiempo me estuve peleando tambien para incluir imagenes en los reportes. Yo no uso BBDD para almacenar las imagenes, estan incluidas dentro del proyecto. No es el mismo caso pero igual te puede ayudar la solución que yo encontré:

    Si le pasaba como parámetro la ruta donde estaba la imagen, me generaba error.

    Solo me extraia la imagen si en el campo de la imagen en la definición del report le ponia:

    http://${baseUrl}/pentaho/GetResource?resource=${pathImage}

    y los paràmetros que le pasaba al report eran:
    - baseUrl: Ruta donde estaba desplegada la aplicación
    - pathImage: Ruta de la imagen

    Espero haberte servido de ayuda, suerte

  5. #5

    Default

    Buen dia jamoreno Muchas Gracias por Responderme,Pero tengo algunas dudas, los parametros baseUrl y pathImage los tengo que crear en desing-studio, y si los tengo que crear me podrias explicar por favor como. y si no hay que crearlos me podrias dar por favor un ejemplo De como quedaria una URL con los parametros ingresados.
    Muchas Gracias.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.