Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: ReportDesigner 1.60 GA (348) can't open file

  1. #1

    Default ReportDesigner 1.60 GA (348) can't open file

    Hi,
    I just downloaded the Reportdesigner 1.60 GA (348).
    It starts normally, but I can't open any report definition.
    Whether I use the "Open File" Icon or the Menu-option "File->Open" I get the following error:
    java.lang.ArrayIndexOutOfBoundsException: 3184
    at sun.awt.shell.Win32ShellFolder2.getFileChooserIcon(Win32ShellFolder2.java:748)
    at sun.awt.shell.Win32ShellFolderManager2.get(Win32ShellFolderManager2.java:248)
    at sun.awt.shell.ShellFolder.get(ShellFolder.java:221)
    at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$LazyWindowsIcon.createValue(WindowsLookAndFeel.java:1865)
    at javax.swing.UIDefaults.getFromHashtable(UIDefaults.java:185)
    at javax.swing.UIDefaults.get(UIDefaults.java:130)
    at javax.swing.MultiUIDefaults.get(MultiUIDefaults.java:44)
    at javax.swing.UIDefaults.getIcon(UIDefaults.java:411)
    at javax.swing.UIManager.getIcon(UIManager.java:613)
    at javax.swing.plaf.basic.BasicFileChooserUI.installIcons(BasicFileChooserUI.java:237)
    at javax.swing.plaf.basic.BasicFileChooserUI.installDefaults(BasicFileChooserUI.java:219)
    at javax.swing.plaf.basic.BasicFileChooserUI.installUI(BasicFileChooserUI.java:135)
    at com.sun.java.swing.plaf.windows.WindowsFileChooserUI.installUI(WindowsFileChooserUI.java:126)
    at javax.swing.JComponent.setUI(JComponent.java:652)
    at javax.swing.JFileChooser.updateUI(JFileChooser.java:1755)
    at javax.swing.JFileChooser.setup(JFileChooser.java:366)
    at javax.swing.JFileChooser.<init>(JFileChooser.java:332)
    at javax.swing.JFileChooser.<init>(JFileChooser.java:285)
    at org.pentaho.reportdesigner.crm.report.commands.OpenReportCommand.execute(OpenReportCommand.java:81)
    at org.pentaho.reportdesigner.lib.client.commands.CommandToolBar$6.actionPerformed(CommandToolBar.java:206)
    at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
    at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
    at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
    at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
    at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
    at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
    at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
    at java.awt.Component.processMouseEvent(Component.java:5488)
    at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
    at java.awt.Component.processEvent(Component.java:5253)
    at java.awt.Container.processEvent(Container.java:1966)
    at java.awt.Component.dispatchEventImpl(Component.java:3955)
    at java.awt.Container.dispatchEventImpl(Container.java:2024)
    at java.awt.Component.dispatchEvent(Component.java:3803)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
    at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)
    at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
    at java.awt.Container.dispatchEventImpl(Container.java:2010)
    at java.awt.Window.dispatchEventImpl(Window.java:1778)
    at java.awt.Component.dispatchEvent(Component.java:3803)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
    at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

    Previous versions (1.5.4.xx) of the ReportDesigner worked well on my workstation.
    I am using MS Vista Business.
    Any ideas?
    Thanks a lot in advance,
    regards,
    Alex

  2. #2

    Default Wrong Java version installed.

    Sorry, my fault! I just switched to Java 1.6 and it worked.
    Regards,
    Alex

  3. #3
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    For reference: This error is caused by JDK bug #6449933, which is fixed in JDK 1.5.0_11 (at least according to the release notes of the JDK). According to the release notes and comments on this bug, this bug is not fixed in JDK 1.6.0. (For JDK 1.6, the bug will be fixed as #6489447; the current fix seems to fail from time to time.)
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  4. #4
    Join Date
    Oct 2007
    Posts
    2

    Default What OS?

    What OS are you using? We are having this problem with Windows, Vista and XP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.