Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: Execute SQL - initialization error

  1. #1
    Join Date
    Jun 2007
    Posts
    2

    Default Execute SQL - initialization error

    Hi to all,
    I just started evaluating the ETL by making very simple transformations. I want to insert one record using an Execute SQL transformation.
    When running the transformation with the Preview or Debug button the record is entered in the DB, while when using the Run button I get the following errors:

    Code:
    2008/01/11 18:27:45 - AggiornaTrans - ERROR (version 3.0.1, build 534 from 2007/12/12 12:28:23) : Errore durante l'inizializzazione del passo [AggiornaTrans]
    2008/01/11 18:27:45 - AggiornaTrans - ERROR (version 3.0.1, build 534 from 2007/12/12 12:28:23) : java.lang.NullPointerException
    2008/01/11 18:27:45 - AggiornaTrans - ERROR (version 3.0.1, build 534 from 2007/12/12 12:28:23) :     at org.pentaho.di.core.database.Database.shareVariablesWith(Database.java:4348)
    2008/01/11 18:27:45 - AggiornaTrans - ERROR (version 3.0.1, build 534 from 2007/12/12 12:28:23) :     at org.pentaho.di.trans.steps.sql.ExecSQL.init(ExecSQL.java:223)
    2008/01/11 18:27:45 - AggiornaTrans - ERROR (version 3.0.1, build 534 from 2007/12/12 12:28:23) :     at org.pentaho.di.trans.step.StepInitThread.run(StepInitThread.java:48)
    2008/01/11 18:27:45 - AggiornaTrans - ERROR (version 3.0.1, build 534 from 2007/12/12 12:28:23) :     at java.lang.Thread.run(Unknown Source)
    Any suggestion ? Is there any other documentation available except the Spoon User Guide ?
    Thanks !

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Lemme guess... you didn't define a connection. Show us the transformation.

    For the rest... look under the docs/english directory, look in the samples directory, also on internet you find a few tutorials.

    Regards,
    Sven

  3. #3
    Join Date
    Jun 2007
    Posts
    2

    Default

    I had share the step without connection, thinking that share works as unhide.
    After opening the transformation, setting the connection and saving, the connection appears as saved in the step, but it wasn't. Strange behavior !
    I have delete all shares and it works.

    Thank you Sven for helping !

  4. #4
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    I've come across this too - it's very easy to do and seems to be handled very badly. Is it worth raising a jira for? (I'm happy to raise one)

    The scenario is, you decide to copy part of a transformation to a new one , by cut and paste, but the new one doesnt have the Database connections defined.

    I then saw what this poster saw as well... In that i added the connection on one step, but it still failed. I had to go into the other step, edit the connection (event though it was set) and test it, click ok, and then it worked.

    This is pdi 3.1.0.826. The exception has now moved to line a:4474) in this version.

  5. #5
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    You should always file JIRA reports if you think something can be improved :-)

  6. #6
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    Ok, this is annoying It works in the simple case. In that you get an error saying connection must be defined.

    Arrgh!

  7. #7
    Join Date
    Jan 2010
    Posts
    1

    Unhappy org.pentaho.di.core.database.Database.emptyAndComm it(Database.java:1403)

    I got this error. I use PostgresSQL DB and Kettle - Spoon 3.2. The problem was because column names had double quotes around them. Guess what the mapping was based on kettle showing the column names. If Kettle picked up the column names, thereby aware of the double quotes, why wouldn't its DML statements have those double quotes?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.