Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: problem to publish to server with Metadata Editor

  1. #1
    Join Date
    Mar 2008
    Posts
    5

    Default problem to publish to server with Metadata Editor

    Hello,

    I have a problem when I try to publish a Model on the Pentaho Server.

    Here are the informations I use :

    Publish Location : samples
    Web Publish URL http://localhost:8080/pentaho/RepositoryFilePublisher
    Publish password (i set it in the config xml file) : password
    server userid: joe
    server password : password


    My problem is that when i click on ok, i have this message :
    unable to save file (metadata.xmi) to server. Correct any server, id , or password erros and try again.


    But I don't understand what is the problem, because the informations on server userid, password,... seem to be good.

    Someone could help me please ?

    Thank

  2. #2
    Join Date
    Jun 2005
    Posts
    115

    Default

    Are you getting any other errors in the server console?

  3. #3
    Join Date
    Mar 2008
    Posts
    5

    Default

    Thank for the answer.

    In fact the port number of the server was not the good

  4. #4
    Join Date
    Apr 2008
    Posts
    7

    Default

    Quote Originally Posted by grenatdu55 View Post
    Thank for the answer.

    In fact the port number of the server was not the good
    I am facing the same problem. Can you please specify where to specify the port number ?

  5. #5
    Join Date
    Apr 2009
    Posts
    1

    Angry

    Hi all,

    I'm having the same issue. i.e.

    Using
    Publish Location : samples
    Web Publish URL http://localhost:18080/pentaho/RepositoryFilePublisher
    Publish password (i set it in the config xml file) : 12345678
    server userid: joe
    server password : password


    My problem is that when i click on ok, i have this message :
    unable to save file (metadata.xmi) to server. Correct any server, id , or password erros and try again.

    I have two instances of Tomcat on my machine. The one used for pentaho uses 18080. HELP!

  6. #6
    Join Date
    Apr 2009
    Posts
    5

    Default

    Quote Originally Posted by grenatdu55 View Post
    Hello,

    I have a problem when I try to publish a Model on the Pentaho Server.

    Here are the informations I use :

    Publish Location : samples
    Web Publish URL http://localhost:8080/pentaho/RepositoryFilePublisher
    Publish password (i set it in the config xml file) : password
    server userid: joe
    server password : password


    My problem is that when i click on ok, i have this message :
    unable to save file (metadata.xmi) to server. Correct any server, id , or password erros and try again.


    But I don't understand what is the problem, because the informations on server userid, password,... seem to be good.

    Someone could help me please ?

    Thank

    HAve you found an answer to this, I came across the problem yesterday, and have not been able to find a solution.

  7. #7
    Join Date
    Apr 2009
    Posts
    5

    Default

    Quote Originally Posted by achaudhry View Post
    Hi all,

    I'm having the same issue. i.e.

    Using
    Publish Location : samples
    Web Publish URL http://localhost:18080/pentaho/RepositoryFilePublisher
    Publish password (i set it in the config xml file) : 12345678
    server userid: joe
    server password : password


    My problem is that when i click on ok, i have this message :
    unable to save file (metadata.xmi) to server. Correct any server, id , or password erros and try again.

    I have two instances of Tomcat on my machine. The one used for pentaho uses 18080. HELP!

    I solved my issue similar to yours. I am a Pentaho Newbie but many years in open source and IT in general. Too many hours searching for this solution, then I saw it in a post here http://forums.pentaho.org/showthread.php?t=66711

    Apparently you cannot publish to samples as is suggested. I created another solution manually and I was able to publish to that location.

  8. #8
    Join Date
    Sep 2013
    Posts
    2

    Default

    I had similar problem - the issue was that max_allowed_packet setting on MySQL was set too small.

    For troubleshooting I recommend looking in pentaho.log (assuming that login/password credentials are OK).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.