Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: adding the filedate to a stream

  1. #1
    Join Date
    Mar 2008
    Posts
    22

    Default adding the filedate to a stream

    I am a newbie to the Pentaho-ETL and I am having trouble adding the filedate to my job stream. My transformation starts with "GetFileNames" then passes it to a "Select Values" hop where I select the "filename" field and on the metadata tab rename the "lastmodifiedtime" to FEED_FILE_DT and convert it to a date format. I then pass the filename to a "Text File Input" step and then finally to a table output step to write it to my database. I get no errors and the FEED_FILE_DT field has nothing but nulls in it. I would appreciate any help possible.

  2. #2

    Default

    I think the "Text File Input" step throws away any input fields coming into it. It might be by design due to it being an "input step", but I'm not the person to answer that.

    What you can do, is to copy the rows from "Get File Names" to two hops, one to "Select Values" and one to "Text File Input", enable "Include filename in output" for the latter and then do a "Merge Join" on the filename to merge FEED_FILE_DT into the stream again.

    I'm sort of a newbie myself, so there might be better ways.

  3. #3
    Join Date
    Apr 2008
    Posts
    1,771

    Default

    If you are still searching for a solution:
    in order to create atext file you have to use the "Text File Output".

    "Text File Input" is used if you need to read a text file and apply some steps to it.

    Hope it helps.
    M.

  4. #4
    Join Date
    Mar 2008
    Posts
    22

    Default Got it

    Thanks Mick, I did finnaly figure out the problem. I apprecaiet the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.