Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Problem with get and set Variables

  1. #1

    Unhappy Problem with get and set Variables

    Hello All...

    I am using Kettle 3.0.2 ......

    Here I am sending my files as attachments... My problem is....

    I am setting 2 variables in one transformation and using those in another transformation as directed by some senior... The problem here is if the transformations are executed separately, independently they are doing fine.... But If i execute a job containing those two tranformation, the job is executing fine but not getting the output....

    Files are:

    part1.ktr and part2.ktr are transformation files and new job.kjb is the job file.

    please help me out...

    Thanks in advance
    Deepak S
    Attached Files Attached Files

  2. #2

    Default

    I've not used variables, but in the samples the one I saw defined the variable 'Valid in the parent job' have you tried something similar, instead of the whole JVM?

    Or possibly rows to results?

    I am taking a wild guess here

    Tom
    Last edited by bugg_tb; 04-22-2008 at 06:07 AM.
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  3. #3

    Unhappy

    Hello...

    I tried with all the 4 options.....

    Here I am sending the snapshot of the job executing....

    The expected output in this case is an: Error stating unique constraint problem... as the data supplied to the First transformation was already in the database....



    Pleas help in this regards
    Attached Images Attached Images  

  4. #4
    Join Date
    Apr 2008
    Posts
    7

    Default

    Hello,

    in the job you have marked option 'Execute for every input row' for every transformation. but in the first transformation don´t have step 'Copy rows to result'. try unmarked the option or put the step into transformation.
    I am not expert, so i am not sure. but I thing that it is reason why it doesn´t go.

  5. #5

    Thumbs up

    Hello...

    try unmarked the option or put the step into transformation.
    I got the output.... by changing some of the checkboxes in the transformation...

    Any ways thanks a lot for ut kind suggestion

    Thanking you all

    Deepak

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.