Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Two problems with CubeDesigner

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Feb 2008
    Posts
    14

    Default Two problems with CubeDesigner

    Hi everyone.

    Basically I'm experiencing two issues with the CubeDesigner, and I'll just post them already (the first error is happenning to a friend of mine who is setting up the CubeDesigner on Windows, though):

    1) On Windows XP, after setting up the first step, the tables/schemas just won't show on the drop-down menu. It somehow shows up for very little time and then the menu goes up again, thus not allowing the selection of any table. Has anyone ever experienced this and know the solution? I think I've had this once when setting it up on Windows but it got randomly fixed. The JDK version is 1.5, and we've tried with both versions of CubeDesigner.

    2) How do I tell the XML file that my primaryKey is not the last level of the hierarchy? I thought that putting the correct attribute (as in the foodmart example) would solve that, but it didn't work. My hierarchy is something like:

    - <Dimension name="Product" foreignKey="product_key" primaryKey="product_key">
    - <Hierarchy name="Product" hasAll="true" allMemberName="All product">
    <Table name="product" />

    <Level name="product.department" table="product" column="department" uniqueMembers="true" />

    <Level name="product.category" table="product" column="category" uniqueMembers="false" />

    <Level name="product.subcategory" table="product" column="subcategory" uniqueMembers="false" />

    <Level name="product.brand" table="product" column="brand" uniqueMembers="false" />
    <Level name="product.key" table="product" column="product_key" uniqueMembers="true" />


    </Hierarchy>


    </Dimension>

    For some reason it keeps comparing the last level of the hierarchy with the column on the fact table, so I can't put like the product description (which is the name of it and it would be the last level).

    Any help would be very appreciated!

    Regards,

    Vitor

  2. #2
    Join Date
    Dec 2006
    Posts
    27

    Default same problem

    i am also using winXP with cubedesigner

  3. #3
    Join Date
    Oct 2007
    Posts
    5

    Default

    Quote Originally Posted by vitorbm View Post
    1) On Windows XP, after setting up the first step, the tables/schemas just won't show on the drop-down menu. It somehow shows up for very little time and then the menu goes up again, thus not allowing the selection of any table. Has anyone ever experienced this and know the solution? I think I've had this once when setting it up on Windows but it got randomly fixed. The JDK version is 1.5, and we've tried with both versions of CubeDesigner.
    It's a really shoddy bug which should be fixed by packaging CubeDesigner, but I solved it by following the guide at the top of this page. It's basically insuring that you're running that specific version of the JRE.. Still come across lots of other bugs, mind, but at least you can see the databases :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.