Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: the chart iamge not shown in pentaho

  1. #1
    Join Date
    May 2008
    Posts
    14

    Thumbs up the chart iamge not shown in pentaho

    i create a brit report with a bar chart, i test the reprot ok in the studio ,but when i publish the report.rtpdign and xaction in pentaho server ,the chat image do not show up, somebody kind tell me why? i m in a fix here.

    what i did: copy two file(*.rptdesign,*.xaction) to solution/sample/reporting/,
    other data show normally except the Chart image

    help me!

  2. #2
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Pentaho Reporting Classic cannot handle BIRT report definitions. So you are probably posting in the wrong forum.
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  3. #3
    Join Date
    May 2008
    Posts
    14

    Default

    what mean ?
    i can not understand, the birt it's self bug???

    tell me more,thank you very much

  4. #4
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    No, you posted the thread in the classic-engine forum. The classic-engine is a independent reporting engine and is not even remotely connected to BIRT. So asking questions about BIRT there was like asking the Pope for advice on good nightclubs in New York.
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  5. #5
    Join Date
    May 2008
    Posts
    1

    Default

    Same problem for me. Is your output format HTML? I was able to see chart in report by switching output format to pdf in the xaction.

    Regards

    Julien

  6. #6
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    The usual pattern for having images in generated HTML, is to put a link to a servlet into the generated HTML and let the servlet deliver the image-file. This is a common pattern among all reporting-engines in the Java-World.

    So check what BIRT is generating, and find out whether the image-url given there is correct. You might have to add a Birt-specific servlet to the configuration, if they use a servlet for shipping the image-data to the browser. But for that, it is the best thing to study the Birt-Documentation, they should explain what they do and how you can do it here ..
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  7. #7
    Join Date
    May 2008
    Posts
    14

    Default

    yes,my output format is HTML. and I was able to see chart in report by switching output format to pdf in the xactio also.

    have you already solve this problem yet?

  8. #8

    Default

    Same for me. The bart chart not show in the report. What's wrong ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.