Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Cannot publish Cubes from Cube Designer

  1. #1
    Join Date
    May 2008
    Posts
    232

    Default Cannot publish Cubes from Cube Designer

    Hello,

    Am not able to publish my cube from Cube Designer. I created through mysql connection. And i had set publish password in 'publisher-config' file.I had started BI Server also.. I don't why it's not getting published..

    Any idea?

  2. #2
    Join Date
    Mar 2007
    Posts
    216

    Smile

    Hi,

    Quote Originally Posted by meenaiyer View Post
    Hello,

    Am not able to publish my cube from Cube Designer. I created through mysql connection. And i had set publish password in 'publisher-config' file.I had started BI Server also.. I don't why it's not getting published..

    Any idea?
    Do you successfully run another Pentaho Cube ?
    If not, following the Quick Start you should be able to do it.
    If yes, tell me

    a+, =)
    -=Clement=-

  3. #3
    Join Date
    Apr 2008
    Posts
    7

    Default

    What is the Error that u are getting.
    Is it something like please check the server id and password?

    Then try restarting the machine and then publishing again.
    It might work.

  4. #4
    Join Date
    May 2008
    Posts
    232

    Question Problem still persisting...

    I tried.But no use..
    Yeah, check whether the username and pwd is correct and BI server is runnig..
    I start the BI server,and i set and save the publisher_config before entering into CD..
    Why am still getting the error???

    Thanks,
    Meena

  5. #5

    Default

    Did you supply the ff correctly?:
    Publish Password = password in publisher_config
    Server Userid = username when logging into BI server
    Server Password = password when logging into BI server

    If you're using pentaho demo, the username/password you may use is: joe/password
    Hope this info helps.

    Regards!

  6. #6
    Join Date
    May 2008
    Posts
    232

    Default Still not working..

    Yepp.. I had given the same... It's not getting published..
    Am using "pentaho-demo' only...

    I just copy, pasted the 'web-url'
    http://localhost:8080/pentaho/RepositoryFilePublisher
    in the internet explorer and i couldn't view that page.. i see the following error..

    HTTP Status 404 - /pentaho/RepositoryFilePublisher
    type Status report
    message /pentaho/RepositoryFilePublisher
    description The requested resource (/pentaho/RepositoryFilePublisher) is not available
    JBossWeb/2.0.0.GA


    Do i face the publishing problem because of this??
    How should i resolve this??

    Thanks,
    Meena

  7. #7
    Join Date
    Apr 2008
    Posts
    7

    Default

    Hi. I was facing the same problem while running pentaho.

    IT means that pentaho has not installed correctly.
    In my case I copy pasted the JBOSS folder ( for pentaho which was running fine on some other machine) into my machine.

    Shut the service in the other m/c and then copy the JBOSS folder.

    The HTTP 404 error tells u that the root page is itself not present. The above solution should work fine.
    Last edited by inamdarvin; 05-26-2008 at 03:28 AM.

  8. #8
    Join Date
    May 2008
    Posts
    232

    Default

    Hi..........

    Which 'jboss' should i replace?? The one inside ' BI server' or the one inside 'pentaho-demo'???
    First i replaced, the one inside 'BI Server', then i could see the login page, but, after i login am getting error... 'HTTP-500'

    Then i replaced both.. Now am getting.. 'page cannot be displayed'...
    Should i change both???

    Thanks,
    Meena

  9. #9

    Default

    If you have specified the correct Publish and Server UID and Passwords you should have no problem publishing the cube. If not, try the ff:
    • Click the 'Back' button in cube designer.
    • Restart Cube Designer and create cube again.
    • Restart BI server and Cube Designer and create the cube again
    • [See the attached picture] and make sure that the path specified in the 'Publish Location' field DOES exist.
    Quote Originally Posted by meenaiyer View Post

    I just copy, pasted the 'web-url'
    http://localhost:8080/pentaho/RepositoryFilePublisher
    in the internet explorer and i couldn't view that page.. i see the following error..

    HTTP Status 404 - /pentaho/RepositoryFilePublisher
    type Status report
    message /pentaho/RepositoryFilePublisher
    description The requested resource (/pentaho/RepositoryFilePublisher) is not available
    JBossWeb/2.0.0.GA


    Do i face the publishing problem because of this??
    How should i resolve this??
    For this problem you do not copy&paste the 'Web Publish URL'. Using the attached picture as an example, the cube was published in the '/samples/analysis' directory. In the BI server this corresponds to the 'Analysis Examples' solution.

    Therefore, you go to the solutions browser of pentaho server and then click the 'Analysis Examples' solution. The name of the cube should be on the list if all went fine. You may also go directly to the URL: http://127.0.0.1:8080/pentaho/Pivot?solution=samples&path=analysis&action=NameOfCube.xaction to view the cube.

    I hope this helps.

    Cheers!
    Attached Images Attached Images  

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2017 Pentaho Corporation. All Rights Reserved.