Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Taking out security

  1. #1
    Join Date
    May 2008
    Posts
    14

    Question Taking out security

    Hello, as part of our testings, as a way to use Pentaho fastly, and while I can put it to work with LDAP server for authentication, I'd like to be able to take out security for a while, What should I do?

    I tryed modifying the file: web.xml this

    <!-- Filter mapping for security. Note that all objects are locked down. We could change this here as desired. -->
    <filter-mapping>
    <filter-name>Acegi Filter Chain Proxy</filter-name>
    <url-pattern>/*</url-pattern>
    </filter-mapping>


    changing url-pattern to something non-existent like: /NONE* this way I could enter the URL for reports:
    http://localhost:8080/pentaho/adhoc/waqr.html

    but Instead of loading my models for reports I get a JavaScript alert with an error message that says:

    "There are either no Business Models defined in the metadata, or you do not have permission to access any of the Business Models. Please create one or more Business Models using the Metadata Editor and then publish them to the Pentaho server. Or, use the Metadata Editor to give the appropriate user permission to access to the Business Model."
    What should I do to bypass security to let users view models to create their own reports without having to log into the system?

    Thanks In Advanced,
    Johnny

  2. #2

    Default

    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  3. #3
    Join Date
    May 2008
    Posts
    14

    Default

    Thanks a lot bugg_tb, I searched in the docs but didn't find it by myself.

  4. #4
    Join Date
    May 2008
    Posts
    14

    Question Still with problems taking out security.

    Still with problems,

    I did all steps suggested in the URL wiki you pointed me out, but I still have problems.
    When I open server through web ( http://localhost:8080/pentaho/ ) I can enter easily, it just opens without asking for password. But when I follow link for reports ( Go -> New Report ), I'm still receiving the error message:

    "There are either no Business Models defined in the metadata, or you do not have permission to access any of the Business Models. Please create one or more Business Models using the Metadata Editor and then publish them to the Pentaho server. Or, use the Metadata Editor to give the appropriate user permission to access to the Business Model."

    Nonetheless that, I have already published successfully a model to my server.
    What could be happening?

    Thanks In Advance,
    Johnny
    P.S: I followed the steps several times, but nothing changed

  5. #5
    Join Date
    Oct 2006
    Posts
    817

    Default

    When you defined your model in Pentaho Metadata Editor, did you give the Anonymous user full access?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.