Hitachi Vantara Pentaho Community Forums
Results 1 to 10 of 10

Thread: ftp move to directory

  1. #1

    Default ftp move to directory

    hi,

    I am trying to use the issue "move to" in the Get files with FTP step, so that the files I am downloading are moved to another directory on the server. Although the test button says the folder exists, the job fails when it tries to move the files to this directory.
    What do I have to do, to move the files I am downloading to another directory in the server that already exists??

    Thanks.

  2. #2

    Default

    Hi Sita,
    Which version of PDI do you use?
    Anyway, please feel free to post a bug :

    http://jira.pentaho.com/secure/Dashboard.jspa

    samatar
    Last edited by shassan2; 06-10-2008 at 12:02 PM.

  3. #3
    Join Date
    Sep 2007
    Posts
    834

    Default

    I had a similar problem. I didn't get any error messages, but the files weren't copied/moved.
    In my case, was a Caption problem. In the jobs I had the names in small letters, and the names of the files had capital letters. I modified the names in the jobs, and everything worked!
    (Windows environment, PDI 3.0.1)


    Quote Originally Posted by sita View Post
    hi,

    I am trying to use the issue "move to" in the Get files with FTP step, so that the files I am downloading are moved to another directory on the server. Although the test button says the folder exists, the job fails when it tries to move the files to this directory.
    What do I have to do, to move the files I am downloading to another directory in the server that already exists??

    Thanks.

  4. #4

    Default

    I'm using v3.1-M2. This is the error message that I get:

    INFO 10-06 15:59:20,207 (LogWriter.javarintln:439) -Get files with FTP - Changed to directory [./message]
    ERROR 10-06 15:59:20,304 (LogWriter.javarintln:436) -Get files with FTP - We can not find the move to folder (on the remote host)!

    ./message is the folder I want to download from and the folder where I want the files to be copied is ./backup (or ../backup if you are in ./message) I have tried both but it doesn't work. The test button says they all exist (./backup and ../backup) although there is only one backup folder, in the same folder as ./message.

  5. #5

    Default

    Hi sita,
    Today, this feature is limited to sub folders.
    I mean backup folder must be a sub folder of message folder (see attached picture).

    Did you tried with ../backup?

    Thanks

    Samatar
    Attached Images Attached Images  

  6. #6

    Default

    both, message and backup are subfolders of the default folder for the connection with the ftp server (if they weren't, I wouldn't even try). and yes, I tried with ../backup with the same result.

    Has this "move to" thing ever worked for you?

  7. #7

    Default

    To be clear..backup must be a sub folder of message :-)
    and yes it worked for me.
    But i opened a bug :

    http://jira.pentaho.com/browse/PDI-1342

    Feel free to add more infos.

    Samatar

  8. #8

    Default

    I'd already unterstood that but, does it have to be that way? Shouldn't I be able to move the files out of the folder where they are?

  9. #9

    Default

    "Shouldn't I be able to move the files out of the folder where they are?"
    I don't know how to do it..until now :-)
    I will make some tests tomorrow.

    Keep one eye on this one :

    http://jira.pentaho.com/browse/PDI-1342

    Thanks and take care

    Samatar

  10. #10
    Join Date
    Oct 2008
    Posts
    7

    Default

    Are there any news about this problem? I tried it with version 3.1.0 and with a subfolder, but I still have the same problem...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.