Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: File Input with different separators

  1. #1
    Join Date
    Jun 2008
    Posts
    2

    Exclamation File Input with different separators

    Hi all,

    My problem is like this:
    I am working with the Text file input and in the file I am processing there are different kind of separators: sometimes it is a space character and sometimes there is simply no separator (from a 7 digit number the first 3 digits belong to one field and the next 2 to another as well as the last 2, for instance).
    I have set all the fields length and position in "Fields" and the separator I am using is empty (I have also used a space), but unfortunately the preview shows that the rows in my file are placed in the first field, without decomposing them.

    I attach the transformation file as well as my .txt input file

    Thanks in advance
    Attached Files Attached Files

  2. #2

    Default

    Hola Daniel,

    Pots provar de tractar de combinar el tractament del fitxer CSV amb l'step Slipt field per millorar els resultats. No he acabat d'entendre molt bé el problema imagino que no et separa quan indiques les posicions fixes no?

    Si m'envies més informació en català et podré ajudar millor

    Sort
    Enric Biosca
    Project Director at ICA

  3. #3
    Join Date
    Sep 2007
    Posts
    834

    Default

    I agree. You have to use a fixed file input instead. Here you have the modified transformation.
    I had to add a last field with 2 columns.

    regards
    Attached Files Attached Files

  4. #4
    Join Date
    Jun 2008
    Posts
    2

    Default Thanks a lot

    Thanks a lot, finally I could solve my problem by setting the file type to Fixed.

    Great job!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.