Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Streaming result set

  1. #1

    Default Streaming result set

    Hi,
    I am getting this error
    Streaming result set com.mysql.jdbc.RowDataDynamic@48b524aa is still active. No statements may be issued when any streaming result sets are open and in use on a given connection. Ensure that you have called .close() on any active streaming result sets before attempting more queries.
    And this error occurs for insert/update step.

    My database is mysql and the configuration is like this:
    connect_timeout = 300
    net_read_timeout = 300
    net_write_timeout = 600

    #innodb config
    innodb_lock_wait_timeout = 300
    innodb_buffer_pool_size = 3G
    innodb_additional_mem_pool_size = 20M
    #innodb_log_file_size = 512M
    innodb_log_buffer_size = 12M
    innodb_flush_log_at_trx_commit = 0
    innodb_data_file_path = ibdata1:100M:autoextend
    innodb_flush_method = O_DSYNC

    I've found that may be I have to disable the mysql option "result streaming (cursor emulation)". i am running PDI 3.1 and in the mysql database configuration window there is no option to enable or disable it. May be I have to add this option to "options" tab, but I didn't find what will be the parameter for it.
    So how can I set the option here in PDI 3.1? or there is another solution for that?
    Please help.

  2. #2

    Default

    Hey I found it
    Its on the front tab of the window. I unchecked it and the problem is solved.
    Great.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.