Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: just inserted key not found

  1. #1

    Default just inserted key not found

    Hi,

    I have a combination lookup/update step followed by an update step on the same table. This update step cannot find the lookup key that has just been inserted by the combination step, even if this has commit size = 1.

    how is it possible?

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    By default the 2 steps run in 2 different threads that use 2 different database connections.
    As such, you are always going to end up with concurrency problems.

    If you enable the "Unique connections" options (Transformation properties dialog / Misc) you are going to be using a single connection for the 2 steps and your problem might go away.

    Matt

  3. #3

    Default

    I forgot to specify that I'm already doing it.

    (MySQL - InnoDB) I also tried setting the isolation level to read uncommitted and it still doesn't work.

  4. #4
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    If you are already running in the same transaction, heck if you're not even using transactions, on the same connection, I wouldn't know what causes that problem.
    Short of putting a blocking step between the two steps I wouldn't know how to solve it. It smells like some DB issue though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.