Hitachi Vantara Pentaho Community Forums
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: JNDI/JDBC Sources not showing up

  1. #1
    Join Date
    Jun 2008
    Posts
    3

    Default JNDI/JDBC Sources not showing up

    Hi, I'm using the Design Studio 1.7.0 Eclipse package. I'm having trouble creating a JNDI connection to my MySQL DB. The DB is running, I can connect to it and I've also installed and successfully run the pentaho demo BI suite using MySQL and it's working fine.

    In the report wizard, I can define a JNDI connection, but nothing shows up in the Driver pulldown.

    hsqldb.jar and the MySQL drivers are both in lib/jdbc. Both were already in that location.

    When I fill out the 'Add JNDI Connection' dialog and press 'Test', I get:

    An error occurred. The message returned was com.mysql.jdbc.Driver

    I've scoured the various sites, and there's nothing resolved about this. Can anyone offer any help?

    Thanks,
    Woody

  2. #2

    Default

    yeah its knackered,

    in the driver enter com.mysql.jdbc.Driver and the other details as listed and it'll work
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  3. #3
    Join Date
    Jun 2008
    Posts
    3

    Default

    I'm already entering the JNDI connection info:

    Name: MySQL-SampleData
    Driver: com.mysql.jdbc.Driver
    ConnectString: jdbc:mysql://localhost/sampledata
    Username: pentaho_user
    Password: .....

    I've also tried '127.0.0.1' instead of localhost. Same thing:

    An error occurred. The message returned was com.mysql.jdbc.Driver

    I can connect to the DB from the command line mysql client using the same user/pwd.

    Is there maybe a different place to copy the mysql jdbc jar file?

    Thanks for the help,
    Woody

  4. #4
    Join Date
    Jun 2008
    Posts
    6

    Default

    Hi,
    I have the same problem, I don't know how to write the connect string with the ingres. where can I find information about it?

    thanks
    R-man,

  5. #5
    Join Date
    Jun 2008
    Posts
    3

    Default

    Quote Originally Posted by wsturges View Post
    I'm already entering the JNDI connection info:

    Name: MySQL-SampleData
    Driver: com.mysql.jdbc.Driver
    ConnectString: jdbc:mysql://localhost/sampledata
    Username: pentaho_user
    Password: .....

    I've also tried '127.0.0.1' instead of localhost. Same thing:

    An error occurred. The message returned was com.mysql.jdbc.Driver

    I can connect to the DB from the command line mysql client using the same user/pwd.

    Is there maybe a different place to copy the mysql jdbc jar file?

    Thanks for the help,
    Woody
    Bump. The jar file is in the correct spot (it was there at install time), but it's still not working. I've tried creating new projects, copying the jar file a bunch of different places, still not working. Is there something I can do to get around this? I'm pretty much at a stand-still here, I'd like to start building some evaluation reports.

    Thanks for any input,
    Woody

  6. #6
    Join Date
    Jul 2008
    Posts
    3

    Default An error occured. The message returned was com.mysql.jdbc.Driver

    I am trying to solve the same JDBC Driver loading issue. Including mysql conneector---.jar works fine with stand alone Report Designer Wizard.

    The same use case does not work with Eclipse - Plugins
    Included Plugins are as follows:

    1.org.pentaho.designstudio.editors.reportwizard_1.7.0.906, 2.org.pentaho.designstudio.editors.core_1.7.0.342
    3. org.pentaho.designstudio.editors.actionsequence_1.7.0.859


    I tried by including mysql conneector---.jar in plugin lib/jdbc/ path , project build classpath settings

    But none of them works..all the time Pressing Test button (after filling the required details) in Add JNDI Dialog throws an Error Message stating that "An error occured. The message returned was com.mysql.jdbc.Driver"

  7. #7
    Join Date
    Jul 2008
    Posts
    1

    Default

    Try this:

    1.- Add MySQL driver to MANIFEST.MF in "pentaho-design-studio\plugins\org.pentaho.designstudio.editors.reportwizard_XXX\META-INF"

    2.- Delete the following:
    • pentaho-design-studio/configuration/org.eclipse.osgi/.lazy
    • pentaho-design-studio/configuration/org.eclipse.osgi/.bundledata
    • pentaho-design-studio/configuration/org.eclipse.osgi/.state

    3.- Restart Eclipse

  8. #8
    Join Date
    Jul 2008
    Posts
    23

    Default

    Quote Originally Posted by jgarciapz View Post
    Try this:

    1.- Add MySQL driver to MANIFEST.MF in "pentaho-design-studio\plugins\org.pentaho.designstudio.editors.reportwizard_XXX\META-INF"

    2.- Delete the following:
    • pentaho-design-studio/configuration/org.eclipse.osgi/.lazy
    • pentaho-design-studio/configuration/org.eclipse.osgi/.bundledata
    • pentaho-design-studio/configuration/org.eclipse.osgi/.state

    3.- Restart Eclipse
    Hi,

    My name is Barbara and I was with this connection problem. Finally, after read jgarciapz post it´s work fine. Thanks!

  9. #9
    Join Date
    Jul 2008
    Posts
    2

    Default

    I tried the same sequence mentioned above and it did not work for me. I am not sure what's wrong with my setup.

  10. #10
    Join Date
    Jul 2008
    Posts
    23

    Default

    Hi pragseem,

    Look the steps I follow:

    1º) I put the mysql-connector-java-5.0.4-bin.jar in:

    \pentaho-design-studio\plugins\org.pentaho.designstudio.editors.reportwizard_1.7.0.906\lib\jdbc

    2º) I wrote in Manifest file:

    lib/jdbc/mysql-connector-java-5.0.4-bin.jar

    3º) I delete:

    pentaho-design-studio/configuration/org.eclipse.osgi/.lazy
    pentaho-design-studio/configuration/org.eclipse.osgi/.bundledata
    pentaho-design-studio/configuration/org.eclipse.osgi/.sta

    And then, I restarted Eclipse. After these steps it worked for me. I wait it works for you too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.