Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Problemas internacionalizando esquema mondrian

  1. #1

    Default Problemas internacionalizando esquema mondrian

    Hola Gente:

    Es la primera vez que posteo, he montado una solución con Pentaho 1.7RC1/Tomcat 5.5, sin grandes problemas. El repositorio está persistido en la base de datos (MySQL), el modelo de negocios lo tengo en una BD SQLServer, hice y publiqué, los modelos relacional (con metadataeditor) para los reportes adhoc y el multidimencional para mondrian con workbench. Ahora bien, al modelo relacional de negocios (metadata.xmi) lo internacionalizo sin problemas, el metadata editor tiene todo para hacerlo y de manera super sencilla. El problema es el modelo mondrian. Segu�* todos los pasos del manual y funcionó todo bien, pero de buenas a primeras dejó de funcionar, creo que es un problema de refresco de Pentaho, aclaro que refresque el repositorio desde las opciones de ADMIN, reinicié el server, hasta restauré el repositorio y todo eso, al final una consulta de análisis con JPivot, siempre muestra lo mismo, las variables de internacionalización al estilo: %{var.var.var}. Los pasos que segu�* son:
    1) en solutions:/system/olap/datasources.xml agregué:
    Provider=Mondrian;Locale=es;DynamicSchemaProcessor=mondrian.i18n.LocalizingDynamicSchemaProcessor;DataSource=miDS
    Mi esquema está en:
    <Definition>solution:/misolucion/datasources/Ventas.mondrian.xml</Definition>
    2) creé los archivos locale.properites y locale_es.properties y los copié en el mismo lugar del esquema.
    3) solutions:/system/mondrian/mondrian.properties agregué:
    mondrian.rolap.localePropFile=/pentaho/pentaho-solutions/misolucion/datasources/locale.properties
    Como les digo, esto funcionó un rato y luego no.
    Tengo la intención de crear una serie de video tutoriales paso a paso de como montar Pentaho, ya que, hasta ahora, mi experiencia con esto va bastante bien, pero antes debo pulir estas asperezas.

    Gracias
    Last edited by magm; 07-25-2008 at 08:42 PM.

  2. #2

    Default Imagenesy aclaración

    Adjunto una imagen para que vean cual es el problema.
    Aclaro que me tomé la molestia de extender mondrian.i18n.LocalizingDynamicSchemaProcessor a una clase llamada magm.mondrian.i18n.LocalizingDynamicSchemaProcessor con la sola modificación de unas salidas por pantalla en el constructor y en el método de procesamiento, cree un jar que la contiene, lo copié en [TOMCAT_HOME]\webapps\pentaho\WEB-INF\lib y cambié pentaho-solutions\system\olap\datasources.xml de forma que cargue esa clase: DynamicSchemaProcessor=magm.mondrian.i18n.LocalizingDynamicSchemaProcessor, luego reinicio el server y cuando quiero examinar un análisis, en la consola del server no pasa nada, supongo que porque directamente no se carga la clase o bien está redireccionado System.out a otro lado, cosa que dudo.
    Attached Images Attached Images  

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.