Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: BIRT parameters page not shown

  1. #1
    Join Date
    May 2008
    Posts
    14

    Question BIRT parameters page not shown

    Hello Everybody,

    I have a couple of BIRT reports, and I need to show them in Pentaho, so I created an xaction file and pointed it out to the rptdesign, and copy them to my solution repository. Both reports have parameters (a selection list box, loaded with data from a DB table, but when I try to execute the reports I don't see the page asking me to enter (select an item ) as parameter, The report doesn't bring any output, just headers of report table, because of the lack of the parameter selection. What is going on? What should I do to see report parameters?
    I have other BIRT reports without parameters and they are sucessfully executed.

    Thanks a lot,

  2. #2
    Join Date
    May 2008
    Posts
    14

    Wink BIRT parameters page not shown [SOLVED]

    Hello everybody,

    I was, finally, able to show report parameters, I just re-checked my xaction file, there are a couple of elements I wasn't using properly:

    Into <inputs> element, there should go tags for every report parameter in the rptdesign, like this one:

    HTML Code:
    <inputs> 
            <output-type type="string"> 
                <default-value>pdf</default-value> 
                <sources> 
                    <request>type</request>  
                </sources> 
            </output-type> 
            <proceso type="string"> 
                <default-value></default-value> 
                <sources> 
                    <request>proceso</request>  
                </sources> 
            </proceso> 
        </inputs>
    The first child is the report format, this isn't working for me right now, but it's not quite important at this moment, cause we need them all in PDF format, but should be great to make it work either.

    the second child tag MUST have the same name as the report parameter withing BIRT rptdesign, as well as the tag value in request.

    At the end of the file, after you have told the name of your rptdesign file you have to put an action tag:

    HTML Code:
     <actions> 
          <action-definition> 
     
            <action-inputs> 
              <output-type type="string"/> 
              <proceso type="string"/> 
            </action-inputs> 
             
            <action-outputs> 
            </action-outputs> 
             
        <component-name>BIRTReportComponent</component-name> 
            <action-type>report</action-type> 
              <component-definition> 
            </component-definition> 
          </action-definition> 
      </actions>
    in action-inputs tag ther should appear, again, your tag with the name of your report parameter.

    Hope this will be useful for someone in the future, like it could be for me.

    Thanks a lot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.