Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: Network error IOException: Address already in use: connect - Windows 2000 and 2003

  1. #1

    Default Network error IOException: Address already in use: connect - Windows 2000 and 2003

    Hi,

    I have a problem with "Network error IOException: Address already in use: connect". I have a job that has a lot of database steps (input, lookup, output...), and when I run it on Windows 2000 it works fine. But if I run on Windows Server 2003 I get network error ioexception when it tries to execute the second transformation whit database steps.

    I think the problem is that windows doesn´t close the sockets soon. How can I modify the value of the windows sockets timeout?

    Thanks in advance.
    Regards.
    Althor.
    Sorry for my bad english, I´m learning
    La Aventura Es La Aventura

  2. #2

    Default

    I have modified the value of TcpTimedWaitDelay into the window register but I get the same exception.
    Sorry for my bad english, I´m learning
    La Aventura Es La Aventura

  3. #3

    Default

    Hi,

    I found something here :
    http://technet.microsoft.com/fr-fr/l...33(en-us).aspx

    Take care

    Samatar
    Samatar

  4. #4

    Default

    Hi Samatar
    Thanks by your answer.

    I´ve modiffied the maxuserport value but that isn´t the solution. I think is some different windows server property configuration.

    Regards.
    Sorry for my bad english, I´m learning
    La Aventura Es La Aventura

  5. #5

    Default

    The best solution to this problem is to enable connection pooling in Kettle, not muck around with your OS settings.

    You're running out of sockets because your job/transform is connecting to the database over and over -- if you run "netstat -n" you'll see a lot of sockets in TIME_WAIT. (not good)

    Luckily it's easy to enable connection pooling in Kettle!

  6. #6

    Default

    I´ll then try it using the connection pool.

    How can I enable it?

    Regards.
    Sorry for my bad english, I´m learning
    La Aventura Es La Aventura

  7. #7

    Default

    I assume you have a connection defined already for your transformation. Simply edit the connection, go to the Pooling tab, and check "Use a connection pool".

  8. #8

    Default

    A lot of thanks rob.

    I´ll try it. I hope it works fine.

    Regards.
    Sorry for my bad english, I´m learning
    La Aventura Es La Aventura

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.