Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: file can not be opened

  1. #1

    Question file can not be opened

    hi all i m getting this strange error
    if u see the bold letter it says cant open the file
    but i have defined a valid connection and i have authurization to access the file..

    i have a view that takes data from 60 old table... and s12wipmonth is one of the table in the view... i m querying the view to get the values.

    java.sql.SQLException: Can't open file: '.\etlsolution_transformation\s12wipmonth.frm' (errno: 24)

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    From mysql help:

    If you get ERROR '...' not found (errno: 23), Can't open file: ... (errno: 24), or any other error with errno 23 or errno 24 from MySQL, it means that you haven't allocated enough file descriptors for the MySQL server.

    The problem here is that mysqld is trying to keep open too many files simultaneously. You can either tell mysqld not to open so many files at once or increase the number of file descriptors available to mysqld.

    To tell mysqld to keep open fewer files at a time, you can make the table cache smaller by reducing the value of the table_cache system variable (the default value is 64). Reducing the value of max_connections also will reduce the number of open files (the default value is 100).

    To change the number of file descriptors available to mysqld, you can use the --open-files-limit option to mysqld_safe or (as of MySQL 3.23.30) set the open_files_limit system variable. See Section 4.2.3, "Server System Variables." The easiest way to set these values is to add an option to your option file. See Section 3.3.2, "Using Option Files." If you have an old version of mysqld that doesn't support setting the open files limit, you can edit the mysqld_safe script. There is a commented-out line ulimit -n 256 in the script. You can remove the '#' character to uncomment this line, and change the number 256 to set the number of file descriptors to be made available to mysqld.

    --open-files-limit and ulimit can increase the number of file descriptors, but only up to the limit imposed by the operating system. There is also a "hard" limit that can be overridden only if you start mysqld_safe or mysqld as root (just remember that you also need to start the server with the --user option in this case so that it does not continue to run as root after it starts up). If you need to increase the operating system limit on the number of file descriptors available to each process, consult the documentation for your system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.