Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Disable Hop for Debug But Table Inputs Still Run

  1. #1

    Default Disable Hop for Debug But Table Inputs Still Run

    I've got one file input copied across many hops and I have been able to disable hops to speed debugging. Everything worked fine until one of my processes had it's own table input:



    Even though the hop upstream of "Unique CustDiv" is disabled, the Table input runs (and takes a lot of time).

    Is there a way to make that Table input not run?

    By the way, if there's a guide to debugging that I could read, a pointer to that might be nice.

    --Dale--

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Temporarily limit the number of rows retrieved in the table input should minimize runtime... else in version <= 3.1 not.

    Regards,
    Sven

  3. #3

    Default

    I do not know a guide to debug, but...

    I hope you are familiar with Java and one IDE. I use Eclipse. Create a kettle project from SVN. Debug it there.
    Also you can run it on machine A with remote debugging enabled. Launch Eclipse on machine B and debug it there. You have to set a breakpoint on a reasonable entry point.
    (You never did remote debugging before? http://www.google.de/search?q=java+remote+debugging)

    Christoph

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.