Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: There was an error during transformation execution

  1. #1
    Join Date
    Jan 2008
    Posts
    17

    Default There was an error during transformation execution

    Hello,

    I am using spoon 304, I can't launch a preview : I get the error below :

    java.lang.NullPointerException
    at org.pentaho.di.ui.trans.debug.TransDebugDialog.refreshStepList(TransDebugDialog.java:228)
    at org.pentaho.di.ui.trans.debug.TransDebugDialog.getData(TransDebugDialog.java:208)
    at org.pentaho.di.ui.trans.debug.TransDebugDialog.open(TransDebugDialog.java:185)
    at org.pentaho.di.ui.spoon.delegates.SpoonTransformationDelegate.executeTransformation(SpoonTransformationDelegate.java:950)
    at org.pentaho.di.ui.spoon.Spoon.executeTransformation(Spoon.java:6205)
    at org.pentaho.di.ui.spoon.Spoon.executeFile(Spoon.java:6194)
    at org.pentaho.di.ui.spoon.Spoon.previewFile(Spoon.java:6184)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.pentaho.xul.EventHandler.handleMenuEvent(EventHandler.java:42)
    at org.pentaho.xul.swt.toolbar.Toolbar.handleMenuEvent(Toolbar.java:92)
    at org.pentaho.xul.swt.toolbar.ToolbarButton.widgetSelected(ToolbarButton.java:53)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(Unknown Source)
    at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
    at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
    at org.pentaho.di.ui.repository.dialog.RepositoryExplorerDialog.open(RepositoryExplorerDialog.java:583)
    at org.pentaho.di.ui.spoon.Spoon.exploreRepository(Spoon.java:2891)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.pentaho.xul.EventHandler.handleMenuEvent(EventHandler.java:42)
    at org.pentaho.xul.swt.menu.MenuBar.handleMenuEvent(MenuBar.java:52)
    at org.pentaho.xul.swt.menu.Menu.handleMenuEvent(Menu.java:117)
    at org.pentaho.xul.swt.menu.MenuChoice.handleMenuEvent(MenuChoice.java:77)
    at org.pentaho.xul.swt.menu.MenuChoice.handleEvent(MenuChoice.java:73)
    at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
    at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
    at org.pentaho.di.ui.spoon.Spoon.readAndDispatch(Spoon.java:866)
    at org.pentaho.di.ui.spoon.Spoon.start(Spoon.java:5638)
    at org.pentaho.di.ui.spoon.Spoon.run(Spoon.java:5739)
    at org.pentaho.di.ui.spoon.Spoon.main(Spoon.java:371)


    If someone has an idea how to solve this issue, thank you to reply.

    Lfa

  2. #2
    Join Date
    Nov 1999
    Posts
    459

    Default Missing image?

    From the error you are doing a debug (not a preview) and there seems to be a missing image for one of the steps. If you have a custom made plug-in check the image settings.
    If you have a reproducable problem (and not a custom made plug-in) please create a Jira bug.

    Thanks,
    Jens

  3. #3
    Join Date
    Jan 2008
    Posts
    17

    Default

    Hello !

    Thanks for your reply.

    In fact the issue is for preview and it is the same for debug.

    Because you spoke about image. I notice something strange.
    I used the icon Modified Java Spript Value but the image is a red square and not at all the icon for this function : does it help ?

    Laurence

  4. #4
    Join Date
    Jan 2008
    Posts
    17

    Default

    Hello,

    I create a Jira Bug - PDI - 1659.

    Laurence

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.