Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Question about "Select Values" Step

  1. #1
    Join Date
    Apr 2008
    Posts
    1,771

    Default Question about "Select Values" Step

    Hi.
    I am using the "select values" step to rename a couple of fields.
    My input file is text file (tab delimited) and the output file is another text file (tab delimited).

    If I select the tab "select & alter" and click on "edit mapping" I have the following message:
    [IMG]file:///c:/temp/moz-screenshot.jpg[/IMG]"Some fields that were configured for the mapping could not be found in the input/output fields. Following fields will be removed:
    Customers --> Customers"

    I have checked and in my input file step I have filled in the fields names and I did the same in the output file step.

    Why "select values" cannot find those fields?
    Is it because I use text files and not database?

    Thanks.
    Mick

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    No, it is because you don't understand how the "Select Values" step works.

  3. #3
    Join Date
    Nov 2007
    Posts
    2

    Smile

    Quote Originally Posted by Mick_data View Post
    Hi.
    ...
    For renaming fields, you don't have to use the "Edit Mapping"-Button. Just fill in the new name for each field in the "Rename to"-Column.

  4. #4
    Join Date
    Apr 2008
    Posts
    1,771

    Default

    @ MarkoLanger:
    Yes, I understood that, but my question was slightly different (maybe I expressed myself wrongly)

    @ Matt:
    From the link, in the "Edit Mapping" section there is:
    Click to open a mapping dialog to easily define multiple mappings between source and target fields.

    Note: Works if there is only one target output step.
    My understanding is that I should have seen my input fields being mapped to my output fields.

    Obviously I have misunderstood how that option works.
    I will look for samples about that.

    Thanks.
    Mick

  5. #5

    Default

    i think you don't need to create a mapping for text file output step, only for steps that have your own fields (e.g table output step), i think =)

    You must right-click in the step and choose "generate mapping against this target step" to do a mapping.

    good look

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.