Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Error on running steel wheel analysis

  1. #1
    Join Date
    Aug 2008
    Posts
    187

    Default Error on running steel wheel analysis

    I try to remove sample and test folders from the solution to make repository updating process faster.
    And now, I want to put the sample solution back to the repository, So I put sample folder to pentaho-solutions folder, and update the repositroy.
    When I try to access steel-wheels -> analysis-> Territory Analysis by Year, the result page comes empty and errors are thrown in the log (attached)
    Before I remove sample folder from the solution, the analysis xaction works fine...

    Could someone give me insight on this ??
    Thanks in advance,

    Specification:
    Pentaho on Tomcat
    Windows server 2003
    pentaho 1.7.0
    mysql 5.0
    tomcat 5.5.9
    jre 1.5.0_09
    Attached Files Attached Files

  2. #2

    Default

    com.tonbeller.jpivot.olap.model.OlapException: Table 'sampledata.time' doesn't exist

    Check your database settings
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  3. #3

    Default

    Agreed -- in some databases the reserved word "time" can't be used as a table name. May need to quote it or rename it in the DDL, model, and samples.

  4. #4
    Join Date
    Nov 1999
    Posts
    1,618

    Default

    I suspect that there is a table called 'TIME' in the 'SAMPLEDATA' database but it is upper case. MySQL on Linux is case sensitive by default whereas on Windows it is case insensitive. If so, the probable cause is the DDL script that created the database. The CREATE TABLE statement should have used quotes around the table and column names. If this is the steel wheels database, then I think this would be a Pentaho bug.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.