Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: pentaho+liferay -> pentaho work but liferay not

  1. #1

    Default pentaho+liferay -> pentaho work but liferay not

    Good evening,

    I read instructions for install pentaho portlet examples into liferay.
    After install process, I saw the pentaho webapp wok fine.
    But when I access to liferay (localhost:8080/web/guest/home) it don't start. This is the error I look:

    http status 500
    javax.servlet.ServletException: Servlet.init() for servlet MainServlet threw exception
    org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
    org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
    org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:261)
    org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
    org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:581)
    org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
    java.lang.Thread.run(Thread.java:595)
    root cause
    java.lang.NoClassDefFoundError
    sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
    sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
    java.lang.reflect.Constructor.newInstance(Constructor.java:494)
    java.lang.Class.newInstance0(Class.java:350)
    java.lang.Class.newInstance(Class.java:303)
    com.liferay.portal.deploy.hot.PortletHotDeployListener.invokeDeploy(PortletHotDeployListener.java:152)
    com.liferay.portal.kernel.deploy.hot.HotDeployUtil._flushEvents(HotDeployUtil.java:122)
    com.liferay.portal.kernel.deploy.hot.HotDeployUtil.flushEvents(HotDeployUtil.java:54)
    com.liferay.portal.servlet.MainServlet.init(MainServlet.java:280)
    javax.servlet.GenericServlet.init(GenericServlet.java:212)
    org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
    org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
    org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:261)
    org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
    org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:581)
    org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
    java.lang.Thread.run(Thread.java:595)





    Can someone help me?

    Liferay version 4.3.2 on Tomcat 6.0
    Pentaho version 1.6

    Thanks
    Danilo

  2. #2
    Join Date
    Jul 2008
    Posts
    8

    Default

    I have the same problem, have you find the solution ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.