Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: Error ORA-01424 on connect

  1. #1
    Join Date
    Oct 2008
    Posts
    3

    Default Error ORA-01424 on connect

    Hi, im using workbench version 3.0.3.11016. I try to connect with an Oracle database using this parameters:

    Driver: oracle.jdbc.OracleDriver
    Connection :jdbcracle:thin:sys as sysdba/password@ip:1521rcl

    I have the latest oracle driver in the corrtect directory, but i can't connect, an exception occurs in JDBCTreeModel, ORA-01424.

    Can anyone help me please?

  2. #2

    Default

    put the Oracle driver in ur workbench\drivers folder to make coonection with Oracle database bcoz by default drivers are not available in ur workbench
    Mr. Manasa Ranjan Panda
    Hyderabad,INDIA
    E.Mail-:manasaranjan.panda@gmail.com
    M.No-+91 9392923252

  3. #3

    Default

    Quote Originally Posted by Manasa_InfoAxon View Post
    put the Oracle driver in ur workbench\drivers folder to make coonection with Oracle database bcoz by default drivers are not available in ur workbench
    If the Oracle driver were not in the right place, I'd think they'd be getting a ClassNotFound exception, not an Oracle error message.

    mbike -- Are you able to connect using that URL from another tool like DBVisualizer or SquirrelSQL? Looks like Oracle is complaining about a bad escape character based on that error message.

  4. #4
    Join Date
    Oct 2008
    Posts
    3

    Default

    The Oracle driver is in the rigth place, the error is not "ClassNotFound Exception", is ORA-01424.

    I can connect to this database with anothers programs, so the url is well.

    I have no problems using Schema Workbench with MySQL, but I still not able to connect with my Oracle database.

  5. #5
    Join Date
    Aug 2007
    Posts
    2

    Default

    The error description for ORA-01424 is missing or illegal character following the escape.

    mbike could you please provide the exception's stack trace plus the exact steps you follow to reproduce this issue?

  6. #6
    Join Date
    Oct 2008
    Posts
    3

    Default

    This is the complete trace of exception:

    09:16:09,010 ERROR [JDBCTreeModel] JDBCTreeModel
    java.sql.SQLException: ORA-01424: falta o no es vßlido el carßcter que sigue al
    carßcter de escape
    at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java
    :112)
    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
    at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
    at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:745)
    at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.
    java:219)
    at oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedSta
    tement.java:970)
    at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStateme
    nt.java:1072)
    at oracle.jdbc.driver.T4CPreparedStatement.executeMaybeDescribe(T4CPrepa
    redStatement.java:854)
    at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStateme
    nt.java:1154)
    at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePrep
    aredStatement.java:3370)
    at oracle.jdbc.driver.OraclePreparedStatement.executeQuery(OraclePrepare
    dStatement.java:3415)
    at oracle.jdbc.driver.OracleDatabaseMetaData.getColumns(OracleDatabaseMe
    taData.java:273)
    at mondrian.gui.JDBCTreeModel.<init>(JDBCTreeModel.java:52)
    at mondrian.gui.JDBCExplorer.setConnection(JDBCExplorer.java:42)
    at mondrian.gui.JDBCExplorer.<init>(JDBCExplorer.java:35)
    at mondrian.gui.Workbench.newJDBCExplorerMenuItemActionPerformed(Workben
    ch.java:928)
    at mondrian.gui.Workbench.access$300(Workbench.java:57)
    at mondrian.gui.Workbench$4.actionPerformed(Workbench.java:311)
    at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:18
    49)
    at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.jav
    a:2169)
    at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel
    .java:420)
    at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258
    )
    at javax.swing.AbstractButton.doClick(AbstractButton.java:302)
    at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1
    000)
    at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMen
    uItemUI.java:1041)
    at java.awt.Component.processMouseEvent(Component.java:5488)
    at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
    at java.awt.Component.processEvent(Component.java:5253)
    at java.awt.Container.processEvent(Container.java:1966)
    at java.awt.Component.dispatchEventImpl(Component.java:3955)
    at java.awt.Container.dispatchEventImpl(Container.java:2024)
    at java.awt.Component.dispatchEvent(Component.java:3803)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212
    )
    at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)

    at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
    at java.awt.Container.dispatchEventImpl(Container.java:2010)
    at java.awt.Window.dispatchEventImpl(Window.java:1774)
    at java.awt.Component.dispatchEvent(Component.java:3803)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
    at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
    read.java:242)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
    ad.java:163)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)

    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)

    at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

  7. #7

    Default [solved]

    I create a Java Eclipse Project and change the method setColumns(DbTable dbt) in JDBCMetada.java to avoid table names with special chars like |, $, = and that starts with BIN.


    /* get all columns for a given table name */

    private void setColumns(DbTable dbt){
    ResultSet rs = null;
    try{

    if ( dbt.name.contains("/") || dbt.name.contains("$") || dbt.name.contains("=") || dbt.name.startsWith("BIN") ) {
    LOGGER.debug("discarding schemaName: "+dbt.schemaName+", name "+dbt.name);
    } else {
    rs = md.getColumns(null, dbt.schemaName, dbt.name, null);
    while(rs.next()) {
    dbt.addColsDataType(rs.getString("COLUMN_NAME"), rs.getString("DATA_TYPE"));
    }
    }
    if ( rs != null ) rs.close();
    } catch (Exception e) {
    LOGGER.error("setColumns", e);
    }
    }

    And recomplie e generate a new lib/workbench.zip (attached) to be run!

    I work's fine!
    Attached Files Attached Files

  8. #8
    Join Date
    Mar 2009
    Posts
    1

    Default

    hi oziel.nieto, i have tried your solution, and connection to database work but when i click on JDBCExplorer the same error appear, so in my honest opinion the problems are hier
    at mondrian.gui.JDBCTreeModel.<init>(JDBCTreeModel.ja va:52)
    at mondrian.gui.JDBCExplorer.setConnection(JDBCExplor er.java:42)
    at mondrian.gui.JDBCExplorer.<init>(JDBCExplorer.java :35)

    JDBCExplorer.java generate an error

    and/or hier

    at oracle.jdbc.driver.OracleDatabaseMetaData.getColum ns(OracleDatabaseMe
    taData.java:273)

    Oracle driver generate error

    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.