Hitachi Vantara Pentaho Community Forums
Results 1 to 17 of 17

Thread: pentaho 2.0 as windows service?

  1. #1
    Join Date
    Oct 2008

    Default pentaho 2.0 as windows service?

    Could anyone provide instructions on how to setup pentaho-tomcat as windows service?

  2. #2


    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(

  3. #3



    I tried with provided link and also tried with file service.bat in my \biserver-ce\tomcat\bin directory but I still do not understand how to force Pentaho work as a service. My Tomcat is running as service but when I try http://localhost:8080/pentaho/ I have got Tomcat 404 Error: "The requested resource (/pentaho/) is not available". My question is, as I have only little experience with application servers, how to make Pentaho working in Tomcat as a service? Is it possible without reinstalling Tomcat? (I have just downloaded and unzipped the folder with Pentaho 2.0 stable...)
    Thanks a lot,
    Last edited by vjan; 03-19-2009 at 02:43 AM.

  4. #4


    Maybe I should mention that when I start Pentaho as an application with batch file start-pentaho.bat everything works fine... the problem is only with running as a service...

  5. #5


    Hi, it is still me, dealing with this issue I have tried lots of things, I used some java service wrapper to create the service, I read the manuals how to deploy the applications to tomcat (about creating app folder in webapps, modyfiing web.xml and server.xml files - but it si already done in tomcat folder!). Whatever I made the tomcat is running as a service again, but still no success with running pentaho in it. Am I the only one with this problem?
    I will be grateful for your suggestions...


  6. #6
    Join Date
    May 2006



    how exactly did you setup the service?

    I used the service.bat script in pentaho-biserver-ce-3.0.0.RC1\biserver-ce\tomcat\bin and this seems to work just fine. So what I did is:

    service install Pentaho

    and this gives me a service called "Apache Tomcat Pentaho", not simply "Pentaho"

    for removal, its the same thing:

    service remove Pentaho

    removes the "Apache Tomcat Pentaho" service.
    kind regards,

    Roland Bouman
    @rolandbouman on twitter
    Author of "Pentaho Solutions" (Wiley, ISBN: 978-0-470-48432-6)
    Author of "Pentaho Kettle Solutions" (Wiley, ISBN: 978-0-470-63517-9)

  7. #7


    I did the same thing but with pentaho-biserver-ce-2.0, is it problem? I recieved just "Apache Tomcat" service. No "Apache Tomcat Pentaho" or "Pentaho" service...

  8. #8


    Hi Vjan,

    just a stupid question: Did you already start the service?

    I'm using Pentaho Server 2.0 stable.
    When I run "service install Pentaho" (thank you for the information, Roland) I have a new service in the windows service list called "Apache Tomcat Pentaho" - but this service is not yet started by default.
    So I had to make a right mouse click on it - "start", wait until it is started and than Pentaho was available in the browser.

    With kind regards,

  9. #9
    Join Date
    Jul 2006

    Default What about 3.0

    I have tried this same process with 3.0 M1 and cannot get the thing to stop saying "description The requested resource (/pentaho/) is not available."

    Any differences for deploying 3.0?


    I am getting a LARGE error log in stdout.log, contents are here:
    Last edited by mikeschuld; 03-31-2009 at 05:10 PM.

  10. #10
    Join Date
    Jul 2006

    Default Even more progress

    Figured out that hypersonic data needs to be running. SO now the issue is to get it to stop looking for hypersonic data!

    Any ideas on that one? I am working on removing the datasource objects from the config files right now. I'll continue updating if I solve it

  11. #11
    Join Date
    Jul 2006

    Default Solution

    Used the process and similar config to what is posted here to run hypersonic as a service and it works great.

    Now I just need to work on speeding it up a bit!

  12. #12


    hey there, I've got the same problem with the "service install pentaho". Did you find a solution for it?

  13. #13

    Default Pentaho 3.5 as a windows service

    Here's what I had to do to get the service to work. In my case my hibernate db is in a MySQL db so those changes have already been done.

    1. Change to tomcat/bin
    2. Run: service install Pentaho
    3. Run: tomcat5w //MS//Pentaho
    4. Right click icon in try and choose "Configure"..
      * Description: Port 8080
      * Startup type: Automatic (Manual for test site)
      * Java Virtual Machine: D:\biserver-ce-3.5.0.stable\biserver-ce\jre\bin\client\jvm.dll
      * Java Classpath: C:\Program Files\Java\jdk1.6.0_16\lib\tools.jar;D:\biserver-ce-3.5.0.stable\biserver-ce\tomcat\bin\bootstrap.jar
      * Java Options:
      * Initial memory pool: 256
      * Maximum memory pool: 768
      * Class: org.apache.catalina.startup.Bootstrap
      * Arguments: start
      * Mode: jvm
      * Class: org.apache.catalina.startup.Bootstrap
      * Arguments: stop
      * Mode: jvm
    5. Apply and save.

  14. #14
    Join Date
    Jul 2006


    eggsurplus: That process works great to get tomcat up and running, but /pentaho/ still doesn't work unless the hypersonic database is started before the service starts.

    What are you doing to circumvent that issue?

  15. #15


    I'm using MySQL so that's how I got around it. MySQL is already started.

  16. #16


    I'm trying to do this, but in my biserver-ce\tomcat\bin i can't find any service.bat... how can i do?

  17. #17
    Join Date
    Feb 2011

    Default Pentaho 3.7 as a Windows Service

    I can't say why the service.bat and other required files are not included in the Pentaho biserver distribution anymore. But you can get them by downloading the regular tomcat distribution, from the Tomcat 6 Downloads page. Be sure to get the "Windows" edition, and the same version that is included with the Pentaho distribution. For Pentaho v3.7.0, I used Tomcat v6.0.29 Windows X86.

    Once you have downloaded and unzipped the tomcat distribution file, look for these three files:

    Copy them into your pentaho tomcat executable folder ([pentaho]\biserver-ce\tomcat\bin). Those are the only files you will need; you can delete the rest of the unzipped files.

    Next, make sure you have the JAVA_HOME environment variable set properly. The easiest way to do this is to run pentaho]\biserver-ce\set-pentaho-env.bat.

    Then run
    service.bat install Pentaho
    ... and it should install the service with the name "Apache Tomcat Pentaho".

    By default, it will install it with Manual startup option, and it will not start the service. So you will need to go to Control Panel/Services, change the startup to "Automatic", and then start the service.

    You might also want to experiment with tomcat6w.exe - it allows you to set memory parameters for running the service.

    Important: Before you can run Pentaho as a service, you must also either run Hypersonic as a service, or else migrate the Hypersonic data to a different platform.
    Last edited by twarfield; 03-15-2011 at 04:08 PM. Reason: Added tip to run set_pentaho_env.bat first

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.