Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: XML Input - No file specified error

  1. #1
    Join Date
    Nov 2008
    Posts
    2

    Default XML Input - No file specified error

    Hello,
    I'm having an issue with Kettle - Spoon version 3.0.3, and I'll admint, most likely it's user error. I'm trying to read in an XML file for XML input. I can browse to the file and select it, and it's contents get read in just fine when I try to preview my transformation. However, when I try to run my transformation, I get this error:

    XML Input.0 - ERROR (version 3.0.3, build 569 from 2008/04/25 11:30:04) : No file(s) specified! Stop processing.

    When I go back into the settings of my XML Input object, the file with my data in it is in the selected file list, so it's not that I'm not adding it. If somebody can tell me how to get it to run instead of preview, I'll be very thankful. The only other weirdness I've noticed is that when I save my transformation and exit Kettle, everything saves fine, but the filename for my xml file is always gone when I re-open Kettle.

    Thanks in advance,
    Ryan

  2. #2
    DEinspanjer Guest

    Default

    Hrm. I tried it in 3.0.4 and couldn't reproduce what you describe. Could you try upgrading to either 3.0.4 or 3.1 and see if it still happens?
    Are you saving the transformation to a repository or to a .ktr file?

  3. #3
    Join Date
    Nov 2008
    Posts
    2

    Default

    I downloaded 3.1 and it's working like a charm now. Thanks a whole bunch.

    Ryan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.