Hitachi Vantara Pentaho Community Forums
Results 1 to 15 of 15

Thread: How to change language in User Interface BI Suite 2.0 RC1

  1. #1

    Default How to change language in User Interface BI Suite 2.0 RC1

    Hello,

    I changed in web.xml the language Configuration form en into de. But the User Console is still in english. I also cannot find any translation file for the user console. What could I do to use the User Console in German language?

    Regards
    Last edited by ITStruppi; 11-25-2008 at 10:48 AM.

  2. #2

    Default

    Is there anyone who can help me? I want to use Pentaho in my language. How can I switch the User Console to my language? Please help me!


    Thanks and Regards

  3. #3
    Join Date
    Sep 2008
    Posts
    19

    Default alternative solution

    u can edit all .cache files

    at tomcat/pentaho/mante
    and mantlelogin


    9CA66AAF3D224ED9F59DBE5400BE23EF.cache
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.cache

    find > replace all

  4. #4

    Default

    This is not really the official way to edit the language? If so, is it planed to edit the language by .properties-file?

    Thanks

  5. #5
    pstoellberger Guest

    Default

    Actually I'm looking for a way to do that myself

    Before 1.7 there have been some .properties files to do that... but obviously they are gone.

    You can translate the Ad-Hoc Reporting by having a look into this folder: biserver-ce\tomcat\webapps\pentaho\adhoc\js\ui\messages\nls\

    Please let me know when you find something on this topic

    -paul

  6. #6
    pstoellberger Guest

    Default

    I just had a closer look at EE 2.0 GA release and there is a folder called: "biserver-ee\tomcat\webapps\pentaho\mantle\messages" with the .properties for localizing... so i guess you just need to wait until the community edition goes GA

    -paul

  7. #7
    Join Date
    Nov 2006
    Posts
    171

    Default

    According to my tests, the regional setting of the server determines the web page language if that setting is another than English. In that case the browser language is ignored. If the regional setting of the server is English, but the browser setting is not English, the browser language is used.
    See also http://forums.pentaho.org/showthread.php?t=60909

  8. #8

    Default

    The newest version "2.0.0 stable" is designed very well:
    in the folder
    "\pentaho-server-ce-2.0.0.stable\biserver-ce\tomcat\webapps\pentaho\mantle\messages"
    there is the file
    "messages.properties"

    You can create an individual file "messages_de.properties" for example for German language support and define in there the labels you wish (as you similarily did for the 1.7.1-version).

    Currently there is only one file: "messages.properties". So there is only support for the English language. How are the further translations handled? If there is no German translation we could do this translation. When we're done we'll upload the file.

    With kind regards,
    Lars

  9. #9
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Create the translation, then create a JIRA case (in the BI-SERVER project; http://jira.pentaho.com/browse/BISERVER ) and attach the translation to that case.
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  10. #10

    Default

    Hi Thomas,
    thanks for the information.
    I attached our German translation of WAQR Ad Hoc Reporting (http://jira.pentaho.com/browse/BISERVER-2717), when we're done we'll create another Jira Issue for the German translation of the Mantle User Interface.

    With kind regards,
    Lars

  11. #11

    Default

    Hi,
    the German Mantle translation you can download here:
    http://jira.pentaho.com/browse/BISERVER-2721

    Lars

  12. #12

    Default

    Hi,
    Did anyone have found where are located the following text(see screenshot) :
    - Select Business Model
    - Make Selections
    - Customize Selections
    - Report Settings

    Thanks in advance,
    Louis
    Attached Images Attached Images  

  13. #13

    Default

    Hi Louis,

    how did you manage to display accentuation? When I edit the .properties file, the signs don't appear correctly in Firefox (strage symbols appear instead). I tried to use codes such as Á and "&#195" but it didn't work!

    Quote Originally Posted by campi View Post
    Hi,
    Did anyone have found where are located the following text(see screenshot) :
    - Select Business Model
    - Make Selections
    - Customize Selections
    - Report Settings

    Thanks in advance,
    Louis

  14. #14

    Default

    These strings are in a file called message_strings.js. It should be in \tomcat\webapps\pentaho\adhoc\js\ui\messages\nls\<your language>.

    Quote Originally Posted by campi View Post
    Hi,
    Did anyone have found where are located the following text(see screenshot) :
    - Select Business Model
    - Make Selections
    - Customize Selections
    - Report Settings

    Thanks in advance,
    Louis

  15. #15

    Default Spanish Translation Ad-Hoc

    Uncompress the file I had attached and paste it inside "nls/es" directory
    D:\proyectos\Datalytics-Demo-Custom\biserver-ce-3.5.2.stable\biserver-ce\tomcat\webapps\pentaho\adhoc\js\ui\messages\nls\es\message_strings.js

    Regards from argentina

    Jorge Arroyo
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.