Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Call DB Procedure

  1. #1

    Default Call DB Procedure

    Hi,

    I have a Call DB Procedure step in a transformation, and am getting the following error:

    ORA-06550: line 1, column 13:
    PLS-00222: no function with name 'RECORD_ERROR' exists in this scope
    ORA-06550: line 1, column 7:
    PL/SQL: Statement ignored

    In the Proc-name field I have "databridge_util.record_error", which has been selected from the list in Pentaho, but I've also tried typing it in manually, and the same error occurs. The step takes two strings as input parameters, and the procedure does not return.

    If I log in using the same connection in a SQL interface, and run exec databridge_util.record_error<'ERROR', 'TEST'>, it works perfectly.

    Can anyone help me with this error? Why would I get the above error message, when Pentaho found the procedure in the first place?

    Regards,
    Joshua

  2. #2

    Default

    Not 5 minutes after posting it here, I found a solution.

    The solution was to delete the value in 'Result name'.

    I'll leave my post up in case someone else has this problem.

  3. #3

    Default

    Yes that's true :-)
    When dealing with procedure, you must leave the result name field EMPTY:

    http://wiki.pentaho.com/display/EAI/Call+DB+Procedure


    Samatar
    Samatar

  4. #4
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    Samatar, perhaps the wiki could be updated to read "should be left blank in case of a procedure" instead of "not used in case of a procedure." I think that would help avoid the confusion.

    Cheers!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.