Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Problem with starting on VISTA

  1. #1
    Join Date
    Dec 2008
    Posts
    11

    Default Problem with starting on VISTA

    Hello,
    I installed yesterday pdi-open-3.1.0-826 on my Vista.
    I can't run the keetle due to the following error.
    I tried to run it with the administration priviliges, but It didn't help. I tried also diffrent JAVA (jdk1.5.0_11, jdk1.6.0_11).
    Could you help? Have you met a similar error?

    Code:
    2008/12/03 17:52:06:958 CET [INFO] DefaultFileReplicator - Using "C"Users\redline\AppData\Local\Temp\vfs_cache] as temporary files store.
    ERROR 02-12 22:52:54,122 - Spoon - Fatal error : java.lang.ExceptionInInitializerError
    ERROR 02-12 22:52:54,126 - Spoon - java.lang.ExceptionInInitializerError
        at org.pentaho.di.trans.StepLoader.readNatives(StepLoader.java:124)
        at org.pentaho.di.trans.StepLoader.init(StepLoader.java:109)
        at org.pentaho.di.trans.StepLoader.init(StepLoader.java:119)
        at org.pentaho.di.ui.spoon.Spoon.initPlugins(Spoon.java:444)
        at org.pentaho.di.ui.spoon.Spoon.main(Spoon.java:395)
    Caused by: java.lang.NullPointerException
        at org.pentaho.di.core.util.ResolverUtil.loadImplementationsInDirectory(ResolverUtil.java:242)
        at org.pentaho.di.core.util.ResolverUtil.loadImplementationsInDirectory(ResolverUtil.java:249)
        at org.pentaho.di.core.util.ResolverUtil.loadImplementationsInDirectory(ResolverUtil.java:249)
        at org.pentaho.di.core.util.ResolverUtil.findInPackage(ResolverUtil.java:222)
        at org.pentaho.di.core.util.ResolverUtil.find(ResolverUtil.java:178)
        at org.pentaho.di.core.util.ResolverUtil.find(ResolverUtil.java:184)
        at org.pentaho.di.core.config.AnnotatedStepsConfigManager.load(AnnotatedStepsConfigManager.java:59)
        at org.pentaho.di.core.config.BasicConfigManager.loadAs(BasicConfigManager.java:46)
        at org.pentaho.di.trans.step.BaseStep.<clinit>(BaseStep.java:77)
        ... 5 more

  2. #2
    Join Date
    Dec 2008
    Posts
    11

    Default

    The problem was caused by "!" in the directory name.

  3. #3
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Ouch, I didn't even know that was allowed on Vista.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.