Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Pan: no ocijdbc10 in java.library.path error

  1. #1
    Join Date
    Oct 2008

    Default Pan: no ocijdbc10 in java.library.path error

    I have post something similar before but could not resolve this issue. I am trying to automate a transformation using pan.

    pan.bat /file:"C:\Script\test4.ktr" /level:Basic > "C:\Script\test4.log"

    I am getting an OCI driver error as below. I am using Windows. I have installed Oracle Client 10.2 and I know Kettle 3.1 also uses v10.2. I think the jdbc drivers are the same version. I googled the error "no ocijdbc10 in java.library.path" and the only thing I found was to add the ocijdbc10.dll path to the PATH environment variable. I have also made a copy of ocijdbc10.dll in the C:\Program Files\Pentaho3-1-0-826\libext\JDBC directory.

    I have spent about a week and tried everything but still cannot get pan to work. Any help would be appreciated.



    INFO 05-12 22:46:19,189 - Pan - Logging is at level : Basic logging
    INFO 05-12 22:46:19,189 - Pan - Start of run.
    INFO 05-12 22:46:24,717 - test4 - Dispatching started for transformation [test4]
    INFO 05-12 22:46:24,837 - test4 - This transformation can be replayed with replay date: 2008/12/05 22:46:24
    ERROR 05-12 22:46:26,079 - Table input.0 - An error occurred, processing will be stopped:
    Error occured while trying to connect to the database
    Error connecting to database: (using class oracle.jdbc.driver.OracleDriver)
    no ocijdbc10 in java.library.path

    ERROR 05-12 22:46:26,079 - Table input - Error initializing step [Table input]
    ERROR 05-12 22:46:26,079 - test4 - Step [Table input.0] failed to initialize!
    INFO 05-12 22:46:26,079 - Table input.0 - Finished reading query, closing connection.
    Unable to prepare and initialize this transformation

  2. #2
    Join Date
    May 2006


    Next step, make sure you only have OR ojdbc14.jar ... they contain different versions of the same classes.

    Last edited by sboden; 12-06-2008 at 06:54 AM.

  3. #3
    Join Date
    Oct 2008


    I got it fixed. This is what I did:

    Make a copy of



    C:\Program Files\Pentaho3-1-0-826\libswt\win32

    And it worked. Hope other people can benefit from this too.


  4. #4


    for me (PDI 3.2.0 ee) it was sufficient to copy only
    ocijdbc10.dll from the 10g client to


  5. #5
    Join Date
    May 2007


    I've tried the above and I still get the same error? Even after copying the .dll and .jar

  6. #6
    Join Date
    May 2010

    Default I'm having the same issue on 4.0

    After spending a lot of time finding this thread and solving my problem on 3.2, I seem to be having it again in 4.0. I have also copied the jar files & dll into the specified locations (the normal dll directory is in my path variable, as well as copying the ocijdbc.dll to the libswt\win32 directory).

    Anyone got any other ideas?

    Edit: I've just realised that this is happening in spoon & kitchen for me, I havn't tried pan. Not sure if that makes a difference (the solution was the same last time). I'm happy to provide any files / logs / time / or general help to get this going.
    Last edited by RowanC; 07-25-2010 at 11:36 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.