Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: Installation Java Errors

  1. #1
    Join Date
    Dec 2008
    Posts
    5

    Default Installation Java Errors

    Attempting to install BI 1.6.0.348 on linux Redhat 4.0. Have installed JRE 1.5.0_07. Error I see when running startdesigner_linux.sh is:

    Exception in thread "main" java.lang.NoClassDefFoundError: while resolving class: org.eclipse.swt.widgets.Display
    at java.lang.WMClassLoader.resolveClass(java.lang.Class)(/usr/lig/libgcj.so.5.0.0)
    at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.5.0.0)
    at java.lang.Class.forName(java.lang.String, boolean, java.lang.ClassLoader) (/usr/lib/libgcj.so.5.0.0)

    Not sure where to proceed from here. Any help is appreciated.

  2. #2

    Default

    that error tells us that you aren't using JAVA you're using GJC, check your paths and libs
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  3. #3
    Join Date
    Dec 2008
    Posts
    5

    Default

    Changed the path setting to PATH=/usr/java/jre1.5.0_17:/bin and still get the same error. Don't understand what needs to be done to get around the GCJ error.
    Is there documentation somewhere on what the environment settings need to be for installation of BI?

  4. #4

    Default

    its not path its JAVA_HOME
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  5. #5
    Join Date
    Dec 2008
    Posts
    5

    Default

    Added JAVA_HOME=/usr/java/jre1.5.0_17/bin to the environment. Same errors popped up. Using java version of 1.4.2. Does this need to be upgraded also? Found nothing in the documentation on what java version to use - only JRE.

  6. #6
    Join Date
    Oct 2006
    Posts
    817

    Default

    JAVA_HOME should not point to bin. Instead do JAVA_HOME=/usr/java/jre1.5.0_17

  7. #7
    Join Date
    Dec 2008
    Posts
    5

    Default

    Thanks. Tried that also to no avail. Here are the PATH and JAVA_HOME settings:

    PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/java:/usr/X11R6/bin
    JAVA_HOME=/usr/java/jre1.5.0_17

    Beginning of the error I receive when trying to install ReportDesigner:

    Warning: -XX:MaxPermSize=256m not understood. Ignoring.
    Warning: -Xms128m not understood. Ignoring.
    Warning: -Xmx256m not understood. Ignoring.
    Exception in thread "main" java.lang.NoClassDefFoundError: while resolving class: org.eclipse.swt.widgets.Display
    at java.lang.VMClassLoader.resolveClass(java.lang.Class) (/usr/lib/libgcj.so.5.0.0)
    at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.5.0.0)
    at java.lang.Class.forName(java.lang.String, boolean, java.lang.ClassLoader) (/usr/lib/libgcj.so.5.0.0)
    at java.lang.Class.forName(java.lang.String) (/usr/lib/libgcj.so.5.0.0)
    at gnu.gcj.runtime.FirstThread.run() (/usr/lib/libgcj.so.5.0.0)
    at _Jv_ThreadRun(java.lang.Thread) (/usr/lib/libgcj.so.5.0.0)
    at _Jv_RunMain(java.lang.Class, byte const, int, byte const, boolean) (/usr/lib/libgcj.so.5.0.0)
    at __gcj_personality_v0 (/home/oracle/Desktop/ReportDesigner/java.version=1.4.2)
    at __libc_start_main (/lib/tls/libc-2.3.4.so)
    at _Jv_RegisterClasses (/home/oracle/Desktop/ReportDesigner/java.version=1.4.2)
    Caused by: java.lang.ClassNotFoundException: java.awt.PointerInfo not found in [file:./, file:./resources/, file:./bin, file:./classes, file:./lib/, file:./lib/acegi-security-1.0.2.jar, file:./lib/activation.jar, file:./lib/annotations.jar, file:./lib/antlr-2

  8. #8

    Default

    Hello !


    It's both JAVA_HOME and PATH env variables.
    JAVA_HOME says where executables are. PATH where librairies are.

    Try to put :
    export JAVA_HOME=/usr/java/jre_1.5.0_17
    export PATH=$JAVA_HOME/bin:$PATH

    Then try :
    which java

    It must show something like : /usr/java/jre_1.5.0_17/jre/bin/java
    If not :
    Edit your $JAVA variable into jboss/bin/run.sh to force Pentaho to use your jre (/usr/java/jre_1.5.0_17/jre/bin/java). Note : On tomcat you must check for a "catalina.sh"

    Regards,

    Cedric
    Cedric CLAIDIERE
    Aprolis
    www.aprolis.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.