Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: How to change the drill through table column name?

  1. #1
    Join Date
    Nov 2008
    Posts
    19

    Default How to change the drill through table column name?

    Dear all,

    I just have a test on two sets of dimensions

    Dimension 1:
    <Dimension name="User" foreignKey="user_id">
    <Hierarchy name="User" hasAll="true" allMemberName="All Users" primaryKey="id">
    <Table name="user"/>
    <Level name="name" caption="Name" column="user_name" uniqueMembers="false"/>
    </Hierarchy>
    </Dimension>

    Dimension 2

    <Dimension name="User">
    <Hierarchy name="User" hasAll="true" allMemberName="All Users">
    <Level name="name" caption="Name" column="user_name" uniqueMembers="false"/>
    </Hierarchy>
    </Dimension>


    The result column name in drill through table for dimension 1 is "user_name" and "Name" for dimension 2.....

    So, what I can set in the dimension 1 to show the result column name as "Name"?

    My mondrian version is quite old and is a plugin for grails.

    Any suggestion is welcome, thx

  2. #2

    Default

    Did someone have an answer for this question ?

    Thanks,
    Louis
    Louis Champion
    J2EE 5 Developper
    France, Paris

  3. #3
    Join Date
    Oct 2009
    Posts
    1

    Default

    Did'u solve that problem?

  4. #4

    Default

    Quote Originally Posted by Endru View Post
    Did'u solve that problem?
    No solution...I have made so other test and I don't understand at all where I've made a mistake. If someone has already met this problem, his point point of view could be really helpful.I am using the last version of the bi-server (3.5.0-stable downloaded from sourceforge).

    - In my localhost environment :
    - I add a new datasource (with the admin console)
    - I publish the new mondrian schema (with schema workbench)
    - I try to see if when I do a drill throught to see if column name(displayed in the screen shot 2) use the Name Attribute (screenshot 1 and 2) and indeed it's use the good field.

    - In my integration environment :
    - I add a new datasource (with the admin console)
    - I publish the new mondrian schema (with schema workbench)
    - I try to see if when I do a drill throught to see if column name(displayed in the screen shot 2) use the Name Attribute (screenshot of the schema workbench) and the problem is the fact that this is the Column Attribute that is used instead of the Name Attribute.

    I don't understand why when I do a drill throught in my integration environment this is the Column Attribute that is used instead of the Name Attribute. Any Idea ?

    I could post the mondrian schema sample that I used if you want.

    Here you can find the screenshots :
    Attached Images Attached Images    
    Louis Champion
    J2EE 5 Developper
    France, Paris

  5. #5

    Default

    I am still trying to figure out why I have this strange behavior. I set log4j to DEBUG mode so I can see the SQL request that is generated.
    Code:
    DEBUG [mondrian.rolap.agg.AggregationManager] DrillThroughSQL: select `T_DIM_PASSATION_MARCHE`.`CATEGORIE` as `Categorie`, `T_DIM_CONSULTATION`.`PROCEDURE_TYPE` as `Procedure - Type`, `T_DIM_TIME_MISE_EN_LIGNE`.`DATE_YEAR` as `Date - Mise en ligne - Annee`, `T_DIM_TIME_MISE_EN_LIGNE`.`DATE_MONTH_NAME` as `Date - Mise en ligne - Mois`, `T_DIM_TIME_MISE_EN_LIGNE`.`DATE_MONTH` as `Date - Mise en ligne - Mois (Key)`, `T_DIM_TIME_MISE_EN_LIGNE`.`DATE_DAY_OF_MONTH` as `Date - Mise en ligne - Jour`, `T_FACT_PASSATION`.`FAIT` as `Nombre de marches` from ...
    As you can see each column used the righ name (name used from the cube schema) as alias so I don't understand why each header of my drill through table use the name of the SQL column insteand ("DATE_MONTH_NAME" intead of "Date - Mise en ligne - Mois").

    I tried to find you in the Pivot.jsp file where the drill through data are loaded from the database without finding it. Actually I am looking into the RendererTag from the com.tonbeller.wcf.component package.

    Any help would be really appeciate.

    Thanks in advance,
    Louis.
    Louis Champion
    J2EE 5 Developper
    France, Paris

  6. #6
    Join Date
    Oct 2013
    Posts
    216

    Default

    Did you got the solutions ?
    -- NITIN --

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.