Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: OpenStreetMaps question

  1. #1

    Default OpenStreetMaps question

    I am running CDF 2.1-RC1 and Pentaho 2.0.0.RC1

    I have my map component set up in my template.html

    Code:
    map =
    {
      name: "map",
      type: "map",
      solution: "dashboards",
      path: "common_routines",
      action: "GetPoints.xaction",
      listeners: ["date"],
      parameters:[],
      parameter:"",
      messageElementId: "messages",
      evolutionElementId: "chart",
      htmlObject: "map",
      executeAtStart: true,
      initPosLon: -122.089533790579,
      initPosLat: 37.4229466472633,
      initZoom: 15,
      expression: function(){return "var icon=''; icon = markers[0]; icon"},
      preExecution:function(){},
      postExecution:function(){},
      preChange:function(){},
      postChange:function(){},
      markers: ["js/OpenMap/OpenLayers/img/marker-gold.png"]
    }
    and when I run the dashboard, the map shows up, but the icon marker doesn't. Obviously I am missing something but I'm not sure what.

    Can someone help me with this?

    Thanks
    Bob

  2. #2
    Join Date
    Jul 2008
    Posts
    14

    Default

    You must fetch your X,Y with xaction in order to display points.
    Did you configure GetPoints.xaction to do that?
    We are working for new cartographic dashboard maybe integrated in CDF.
    Please look at www.geobi.org and http://code.google.com/p/geobi/

    Fabio D'Ovidio

  3. #3

    Default

    When stepping through the code during the creation of the component and the display of the component for the 1st time, it doesn't run the xaction it instead uses the initial Latitude and Longitude values that I assigned to the component. Any time after that it will use the latitude and longitude values retrieved from the xaction. Irregardless, I'm not getting the markers to show up.

  4. #4
    Join Date
    Jul 2007
    Posts
    2,497

    Default

    in cdf 3.0 there's a working example. I can't possibly guess what's wrong in your case, using an older version
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  5. #5
    Join Date
    Jul 2009
    Posts
    22

    Default

    Hello,

    I don't have any problems with one map in html. But i want 2 maps: one calls one xaction (sales values) and the other calls another xaction (sales quantity). When i see the result, only the second map has the target results and when i move the map, both are moved.

    I supose i can't work with two maps, right?

    Thanks
    Ana Martins

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.