Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: trying to connect to postgres database

  1. #1
    Join Date
    Mar 2009
    Posts
    2

    Default trying to connect to postgres database

    My url I am using is
    jdbcostgresql://localhost:5432/dm_JobCosting

    The error I am getting is
    exception: java.sql.SQLException: No suitable driver found for jdbcostgresql://localhost:5432/dm_JobCosting

    I added to my classpath in windows where the driver is
    .;C:\Program Files\PostgreSQL\8.1\jdbc\postgresql-8.1-410.jdbc3.jar

    I have also changed the weka.ini file to be
    cp=%CLASSPATH%;C:/Program Files/PostgreSQL/8.1/jdbc

    none of this has helped

  2. #2
    Join Date
    Aug 2006
    Posts
    1,741

    Default

    Hi,

    You might need to watch spaces in your classpath entries. Try enclosing the entry for the jdbc jar in double quotes. Another thing to look at is the System Info (select "SystemInfo" from the "Help" menu in Weka) - see what is recorded for the java.class.path property.

    Cheers,
    Mark.

  3. #3
    Join Date
    Jul 2007
    Posts
    1,013

    Default

    If the double quoting Mark suggested does not help, maybe something in this thread can:

    http://forums.pentaho.org/showthread.php?t=66622

    It was written for Oracle, but it should be easy to adapt it to Postgres.

    Cheers!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.