Hitachi Vantara Pentaho Community Forums
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Unexpected error occurred while launching entry

  1. #1
    Join Date
    Mar 2009
    Posts
    29

    Default Unexpected error occurred while launching entry

    Hi Experts,

    I am facing kettle exceptions while running my job in 3.1, need your comments whether am I missing anything.

    The exception says:
    ERROR - Thread[Thread-2,5,main] - org.pentaho.di.core.exception.KettleException:
    Unexpected error occurred while launching entry [JOB2]


    Job was designed using kettle 2.4 and the same job runs without any issues when executed in kettle 2.4 environment. This job say JOB1 has hop to another JOB2 and see errors related to JOB2.

    I doubt the issue is related to any jars else ClassNotFound error could have been thrown.

    The detailed exception is as follows:

    ERROR - Thread[Thread-2,5,main] - java.lang.NullPointerException
    at org.pentaho.di.job.entries.job.JobEntryJob.verifyRecursiveExecution(JobEntryJob.java:704)
    at org.pentaho.di.job.entries.job.JobEntryJob.execute(JobEntryJob.java:403)
    at org.pentaho.di.job.Job.execute(Job.java:410)
    at org.pentaho.di.job.Job.execute(Job.java:511)
    at org.pentaho.di.job.Job.execute(Job.java:511)
    at org.pentaho.di.job.Job.execute(Job.java:511)
    at org.pentaho.di.job.Job.execute(Job.java:511)
    at org.pentaho.di.job.Job.execute(Job.java:511)
    at org.pentaho.di.job.Job.execute(Job.java:511)
    at org.pentaho.di.job.Job.execute(Job.java:511)
    at org.pentaho.di.job.Job.execute(Job.java:511)
    at org.pentaho.di.job.Job.execute(Job.java:296)
    at org.pentaho.di.job.Job.execute(Job.java:264)
    at org.pentaho.di.kitchen.Kitchen.main(Kitchen.java:354)


    Please let me know your comments.

    Regards,
    Neuron

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Looks like you have a job without a name somewhere.

  3. #3
    Join Date
    Mar 2009
    Posts
    29

    Default

    Thanks MattCasters for the quick turn around. I have been debugging this entire two days but no result.

    The same job works fine in kettle 2.4, I checked again each step has name.
    It gives me errors immediately after this line:
    INFO - Create Batch - Loading job from XML file : [/opt/myjobs/JOB2.kjb]

  4. #4
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    I said Job, not step.

  5. #5
    Join Date
    Mar 2009
    Posts
    29

    Default

    Ohh...sorry I missed that earlier.

    Now I see most of my transformations and Jobs don't have "Name of Job" entry field but the 'Job Entry Name' has been set properly for jobs and transformations.

    Great! after giving job names it has proceeded now. Thanks a lot MattCasters.

    I am wondering how is this working without any issues in kettle 2.4???

    Regards,
    Neuron

  6. #6
    Join Date
    Nov 1999
    Posts
    9,729

    Default Message 30,000!

    Congratulation Neuron, what a great way to make a 30,000 post on this forum :-)

    Yeah, we systematically ask for a job or transformation name to be filled in these days. Back then it wouldn't matter too much. I guess if someone would file a bug report for this thread we could fix it too.

    Cheers,
    Matt

  7. #7
    Join Date
    Mar 2009
    Posts
    29

    Default

    Yeah Matt! Really fantabulous way to make this 30,000 post.
    And I really appreciate your timely help.

    Now I am able to proceed, although getting other exceptions as I am moving on, will need your expert comments on that.
    Note all these jobs are working in 2.4 so mostly it will be upgrade issues or the issues which were not looked in 2.4 timeframe and got fixed in 3.1

    Regards,
    Neuron

  8. #8
    Join Date
    Mar 2009
    Posts
    29

    Default no dbjodbc9 in java.library.path

    Hi MattCasters,
    Last night I was able to proceed further with your hints, now encountering more issues:
    1. If I try to run kitchen.sh with an '&' (background) towards end, I was facing exceptions. Please can you provide your comments. Well after removing '&' it succeed.

    2. I am using IAnywhere driver while connecting to database, the jodbc.jar is copied in libext folder. I get following exception:
    Error connecting to database: (using class ianywhere.ml.jdbcodbc.IDriver)
    no dbjodbc9 in java.library.path


    As you know from yesterday, both these issues does not occur in 2.4

    Regards,
    Neuron

  9. #9
    Join Date
    May 2006
    Posts
    4,882

    Default

    For 2... a hunch. You need libdbjodbc9.so as well... Why it worked in 2.4 and not in 3.x... JDBC drivers change. Either the drivers were deleted because of licensing issues (and you have to add them yourself), or they were upgraded.

    Google a bit for the error message... you'll find more people in the same situation.

    Regards,
    Sven

  10. #10
    Join Date
    Mar 2009
    Posts
    29

    Default

    Thanks Sven. Yes correctly said, before posting the reply i did check and the libdbjodbc9.so is also present.
    The 'jar' and 'so' both present at correct locations.

    Can you please elaborate:
    Either the drivers were deleted because of licensing issues (and you have to add them yourself), or they were upgraded.

    Well the 1st issue I am getting in 3.1, never faced in 2.4 timeframe. Please comment.

    Regards,
    Neuron

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.