Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: Birt 2.3.1 And Pentaho 2.0.0

  1. #1

    Default Birt 2.3.1 And Pentaho 2.0.0

    Hello all,
    I have follow this thread to integrate a Birt report in the Pentaho platform : http://forums.pentaho.org/showthread...d=1#post211528
    . I don't suceed to do this.

    After have do the changes quoted in the thread, I can't run my Pentaho platform and I have this error message:

    "!ENTRY org.eclipse.birt.core 4 0 2009-04-10 14:22:18.168
    !MESSAGE
    !STACK 0
    org.osgi.framework.BundleException: Exception in org.eclipse.birt.core.internal.plugin.CorePlugin.start() of bundle org.eclipse.birt.core.
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1028)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:984)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:489)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:211)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:321)
    Caused by: java.lang.NoSuchMethodError: org.eclipse.birt.core.framework.Platform.setContextClassLoader(Ljava/lang/ClassLoaderV
    at org.eclipse.birt.core.internal.plugin.CorePlugin.start(CorePlugin.java:29)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:1009)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1003)
    ... 10 more
    Root exception:
    java.lang.NoSuchMethodError: org.eclipse.birt.core.framework.Platform.setContextClassLoader(Ljava/lang/ClassLoaderV
    at org.eclipse.birt.core.internal.plugin.CorePlugin.start(CorePlugin.java:29)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:1009)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1003)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:984)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:489)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:211)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:321)

    !ENTRY org.eclipse.osgi 4 0 2009-04-10 14:22:18.184
    !MESSAGE Bundle initial@reference:filelugins/org.eclipse.birt.core_2.3.1.v20080912.jar/ [4] is not active."

    If someone knows what can I do to solve this error?

    edit:
    "And now I have tested with an report from Birt 2.2.1 on the Pentaho platform, and I can just see my table header and I have one big error message."

    Someone has had this before?

    Thank you in advance.

    Nicolas.
    Last edited by nicolas.soyeur; 04-10-2009 at 09:16 AM. Reason: test with 2.2.1 version

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.