Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Data in legend of PieChart does not match actual values returned from query

  1. #1
    Join Date
    Mar 2009
    Posts
    15

    Default Data in legend of PieChart does not match actual values returned from query

    I generated a dashboard using CDF that consists of a piechart showing budget for all regions which then renders a dialchart for each of those region.

    The problem that I noticed is the numbers on the legend of the piechart are not the ones that the query generates. It is based on a percentage value of all the rows and looks like it is something that the CDF generates.

    For example, if My query returned :
    Region 1 : 2000
    Region 2 : 5000

    , the data in the legend would NOT read 2000 against Region 1 And 5000 against Region 2.It would read as 29% for Region 1 and 71% for Region 2.

    Is there a solution to this problem?

    A response would be much appreciated.Thanks!

  2. #2
    Join Date
    Jul 2007
    Posts
    2,497

    Default

    What problem? That's correct. That 2000 is 29% of the total (7000) and 5000 is 71% of the total.

    That's the behavior of jfreechart, not CDF.

    Iirc, if you hide/show legend, the tooltip is different, try it
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  3. #3
    Join Date
    Mar 2009
    Posts
    15

    Default

    The percentage is correct but not the actual number itself. I do not see 2000 and 5000 but some other numbers such that one is 29% and the other is 81%.
    This is what I am trying to figure out.

    Many thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.