Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Address not found for dashboards url

  1. #1

    Default Address not found for dashboards url

    Hi!
    i am trying to create my own dashboards using the CDF.

    i have edited the sample to point to my own folder solutions and path.
    i have created a url that points to:
    http://Dashboards?solution=Dashboard...emplate=mantle

    my directory is as follow:
    Dashboards>>Project>>dashboards

    However, i cannot get the dashboard to work.
    May i know what i have miss out or done wrongly?

    Thanks
    Choon Boon

  2. #2
    pstoellberger Guest

    Default

    1. Which version of the biserver are you using?
    2. What is your exact folder structure for that? pentaho-solutions/Dashboards/Project/dashboards/ ?
    Are you sure about the s in Dashboards?

  3. #3

    Default

    Hi! thanks for replying.
    i am using bi-server-2.0.0.stable
    yup, my exact structure is pentaho-solutions/Dashboards/Project/dashboards/
    yes, i am sure about the 's'.
    I am using windows xp.

    There is one more thing i realise:
    i tried with the cdf samples, i was looking at the properties (right-clicked>>properties) look at their url:
    http://Dashboards?solution=....

    i accidentally pressed apply button and it become:
    http://dashboards/?solution=.....

    after that, the sample cannot work anymore and keeps getting the following error(Same error as what i get from my dashboard):

    Code:
    Address Not Found
    Firefox can't find the server at dashboards.
    Even i try to change back the url, still cant work.

    What could have cause this?

    Thanks
    Choon Boon

  4. #4
    pstoellberger Guest

    Default

    With what are you trying to open the .url file and change the link?
    Open the dashboard.url file with Pentaho Design Studio (in Text editor) and compare it with .url's from the samples

  5. #5
    Join Date
    Jul 2007
    Posts
    2,497

    Default

    Somewhere, you're using an absolute link /Dashboards instead of Dashboards only
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  6. #6

    Default

    hi! thanks for replying.
    i got it working now.

    in case there is another one like me, this is what you should be setting in:

    URL=Dashboards?solution=.....&path=....&template=....
    (set this in text editor)
    or
    URL=http://localhost:8080/pentaho/Dasboards?solution=.....&path=...&template=....
    (set this in text editor or straight from right-click>>properties of url file)

    Do not set it as:

    URL=http://Dashboards?solution=....&path=...&template=....

    (Thought it appears to be like this when you right-click>>properties the .url file)

    Thanks
    Choon Boon

  7. #7

    Default

    thats right pmalves!

  8. #8
    pstoellberger Guest

    Default

    Thats why i suggested to open the .url file :-)
    I saw that behaviour already. Right click on windows doesn't do the same job as editing the .url file. never trust windows

    hf with your dashboard

  9. #9

    Default

    yup.. thats right!
    i did what you say and thats where i saw the difference in the URL declaration and got it working.

    Thanks everyone for their contributions!
    Choon Boon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.