Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Adhoc reporting error connection database

  1. #1

    Default Adhoc reporting error connection database

    Hi !

    I created business views with Pentaho Metadata Editor. The connection I use is JNDI. I published the XMI file on the server. So, when I click on "New Report" in the Web User Console of Pentaho, I see my views, i can select fields but when i want to visualize the report, there is an error :
    AdhocWebService.ERROR_0012 - Failed to generate the report preview. Please check the server log for details of the error.
    When i see the log, it's writting :
    2009-05-29 11:00:20,395 ERROR [org.pentaho.platform.plugin.action.pentahometadata.MQLRelationalDataComponent] Error Start: Pentaho Pentaho Platform Engine Core 2.0.0.stable.35509
    2009-05-29 11:00:20,395 ERROR [org.pentaho.platform.plugin.action.pentahometadata.MQLRelationalDataComponent] Error Start: Pentaho Pentaho Platform Engine Core 2.0.0.stable.35509
    2009-05-29 11:00:20,410 ERROR [org.pentaho.platform.plugin.action.pentahometadata.MQLRelationalDataComponent] 22f68a1d-4c2f-11de-8fd8-89fc45be5ddc:COMPONENT:context-19568451-1243587620145:InMemorySolutionConnectFactory.ERROR_0001 - [fr_1] Database connection could not be established to: testa
    org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create JDBC driver of class '' for connect URL 'null'
    It's probably a problem with the connection to the database...? Have I to put the parameters of my connection somewhere ? I tried to add it in the admin console but I have another error in the log when I try to visualize teh report :
    2009-05-29 11:10:59,432 ERROR [org.pentaho.platform.plugin.action.pentahometadata.MQLRelationalDataComponent] Error Start: Pentaho Pentaho Platform Engine Core 2.0.0.stable.35509
    2009-05-29 11:10:59,432 ERROR [org.pentaho.platform.plugin.action.pentahometadata.MQLRelationalDataComponent] Error Start: Pentaho Pentaho Platform Engine Core 2.0.0.stable.35509
    2009-05-29 11:10:59,447 ERROR [org.pentaho.platform.plugin.action.pentahometadata.MQLRelationalDataComponent] 9fdbd942-4c30-11de-8f3a-1b3a47474ae1:COMPONENT:context-29444893-1243588259182:InMemorySolutionSQLBaseComponent.ERROR_0006 - Impossible dexécuter {0}
    java.sql.SQLException: [JDBC OpenEdge Driver]:Optional feature not implemented.
    "Optional feature not implemented" ?? what's that ?

    There is something I don't understand or something that I forget...

    Thank you !

    EDIT : My connection test in the admin console is ok
    Last edited by Borowsky; 05-29-2009 at 05:27 AM.

  2. #2

    Default

    littl'up !

  3. #3
    Join Date
    Apr 2007
    Posts
    2,009

    Default

    If it tests ok in the admin console, presumably you added your jdbc driver to the admin console to make that work; Is it possible you forgot to add the driver to the platform as well? Or it was added to the platform in the wrong place? ( needs to be added to both apps. )

  4. #4

    Default

    I put my driver file in :
    biserver-ce\tomcat\common\lib
    biserver-ce\tomcat\webapps\pentaho\WEB-INF\lib
    \biserver-ce\tomcat\server\lib

    I don't know if there is an other repertory where i can put my driver...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.