Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Problemas con Workbench.sh

  1. #1
    Join Date
    May 2009
    Posts
    13

    Default Problemas con Workbench.sh

    Estimados,

    Tengo problema para ejecutar workbench. Tengo instalada y funcionando el bi-server pero al ejecutar el archivo workbench.sh me sale el siguiente error:

    "workbench.sh: line 40: syntax error near unexpected token ´do
    workbench.sh: line 40: ´for i in ´ls drivers/*.jar´; do"

    Esto esta instalado en Linux, Centos5.

    He intentado cambinado el archivo por uno que encontré en internet, pero no me ha servido.

    De antemano gracias.

    Fernanda.

  2. #2
    Join Date
    Dec 2008
    Posts
    132

    Default

    Has intentado probar con otra versión de workbench??

  3. #3

    Default

    ¿Que versión de Java tienes instalada?





    Namarie.
    Pentaho User.

  4. #4
    Join Date
    May 2009
    Posts
    13

    Default

    si he probado con otras versiones del workbench, y el error es el mismo.

    Tengo instalado workbench 2.3.2.9247 y java 1.4.2

    Esto esta instalado en una maquina virtual que encontre en Centos con el bi-server 2.0 ya instalado. Esto funciona perfectamente.

    Como hago para instalar todo nuevamente? llegar y bajar las carpetas igual que en windows?
    Yo tenia instalado todo (bi-server y workbench) en windows pero me tiraba un error a la hora de publicar el cubo, el siguiente error:
    "Caused by: java.sql.SQLException: Table not found in statement [select max ("proyecto"."aporte") as "m0" from "proyecto"]..."

    Yo probe esa consulta en el workbench sin las comillas, y me tira un resultado, por lo que pienso que las comillas molestan, pero no sé como sacarlas, es por eso que intente con linux, pero no he podido ni siquiera instalar el workbench :P

    te agradeceria mucho que me pudieras ayudar... estoy estancada hace tiempo con esto... Gracias por la ayuda!!!

    Atte.
    Fernanda.

  5. #5

    Default

    Fernanda...

    Yo lo que te puedo recomendaria es actualisar a la vercion de java.

    Aqui te paso mi worbench.sh para comparar.
    Attached Files Attached Files
    Pentaho User.

  6. #6
    Join Date
    May 2009
    Posts
    13

    Default

    muchas gracias por la ayuda... actualizé la version de java pero todo siguió igual. Investigando por internet, encontré una máquina virtual con pentaho instalado y configurado sobre ubuntu, utilizando mysql, y es eso lo que estoy utilizando hoy para trabajar con pentaho... más fácil :P

    Gracias!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.