I designed a cube and tried to set access controls for the cube by adding roles. But the access levels i designed is not reflecting when i viewed the cube via Pentaho User Console.
Tools Used:
===========
Pentaho Community Edition BI Suite 3.0 RC2
Schema Workbench 3.0.4
Datasource: HSQLDB
Database: SampleData
The steps i followed in the above issue is,
Step 1:
*******
I designed a cube using Schema Workbench 3.0.4, which will list all the cities, the customer names in each of those cities, and number of customers in each city. This cube has a role called 'Admin' for which, the dimension 'Cities' has to be hidden.
Schema for the cube is as follows,
**********************************
<Schema name="CubeTesting">
<Cube name="CustomerCube" cache="true" enabled="true">
<Table name="CUSTOMERS" schema="PUBLIC">
</Table>
<Dimension type="StandardDimension" foreignKey="CUSTOMERNUMBER" name="Cities">
<Hierarchy hasAll="true" allMemberName="All Cities">
<Table name="CUSTOMERS" schema="PUBLIC">
</Table>
<Level name="Country" column="COUNTRY" type="String" uniqueMembers="true" levelType="Regular" hideMemberIf="Never">
</Level>
<Level name="City" column="CITY" type="String" uniqueMembers="true" levelType="Regular" hideMemberIf="Never">
</Level>
</Hierarchy>
</Dimension>
<Dimension type="StandardDimension" foreignKey="CUSTOMERNUMBER" name="CustomerNames">
<Hierarchy name="New Hierarchy 0" hasAll="true" allMemberName="All Customers">
<Table name="CUSTOMERS" schema="PUBLIC">
</Table>
<Level name="CustomerName" column="CONTACTFIRSTNAME" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never">
</Level>
</Hierarchy>
</Dimension>
<Measure name="CustomerCount" column="CUSTOMERNUMBER" datatype="Integer" formatString="####" aggregator="count" visible="true">
</Measure>
</Cube>
<Role name="Admin">
<SchemaGrant access="none">
<CubeGrant cube="CustomerCube" access="all">
<DimensionGrant dimension="Cities" access="none">
</DimensionGrant>
</CubeGrant>
</SchemaGrant>
</Role>
</Schema>
Step 2:
*******
I published the cube into the pentaho server in the following path "biserver-ce\pentaho-solutions\bi-developers\analysis" (username & password used to publish was 'Joe' & 'password' respectively)
Got 'Publish successful' message as well.
Step 3:
*******
Again, in pentaho user console, logged in as user 'joe' who has the role 'Admin'.
Clicked on 'New Analysis View' button. It listed out the schema and cube i published in step 2.
Step 4:
*******
In the analysis view window, it is showing the complete cube instead of hiding the dimension 'Cities' which was orginally expected based on my 'Dimsension Grant' setting in schema file.

If anyone can guide me on this, it will be really helpful. Or let me know if you need more details.
Please advice.
- Senthil Kumar.