Hitachi Vantara Pentaho Community Forums
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Pentaho Cube - role setup not working

  1. #11

    Post

    Hi,
    try with this steps:

    1- Stop the biserver
    2- Edit the file pentahoObjects.spring.xml located in /biserver-ce-3.8.0-stable/biserver-ce/pentaho-solutions/system and uncomment this lines:

    <bean id="Mondrian-UserRoleMapper"
    name="Mondrian-One-To-One-UserRoleMapper"
    class="org.pentaho.platform.plugin.action.mondrian.mapper.MondrianOneToOneUserRoleListMapper"
    scope="singleton" />
    3- Start the biserver
    4- Define the same role names in the Worckbench and in PAC and define the grant permissions for every role.

    This method of Role mapper is one of the three available in Pentaho.

    Bye,

    Marcos Pierri

  2. #12

    Default

    Still can see everything....

  3. #13

    Default

    Hi,
    how do you define the roles and grants in Workbench??

  4. #14

    Default

    as in attached screens
    /deleted/
    Last edited by Bezan; 10-18-2011 at 05:34 AM.

  5. #15

    Default

    Hi,
    what are you trying to restrict??. Can you tell me what is the expected behavior?

  6. #16

    Default

    There are 2 cubes: Sales, Excel.
    I would like role MAG to allow access only to Excel cube.

  7. #17

    Default

    Hi,
    in the role MAG define another "Cube Grant" and in the attributes, Acces: none and cube: Sales. With this option you shouldn't access the Excel cube with the MAG rol.

    bye,

    Marcos

  8. #18

    Default

    I added another Cube Grant.
    Now entering Excel I have only "Slicer:" text and no data
    Trying open Sales cube i have following error: "An error occurred while rendering Pivot.jsp. Please see the log for details."

  9. #19

    Default

    Hi,
    in the MAG role delete the "Dimension Grants" and the "Hierarchy Grant". You should have only defined the "Cube Grant".
    The error trying open the Sales cube, I suppose is about the cube grant restriction. See the log file "pentaho.log" in /biserver-ce/tomcat/bin/ to be sure.

    bye,

    Marcos

  10. #20

    Default

    I think cube with "all" is working ok. There is still problem with "none". In log there is: "MDX cube 'Sales' not found". It is not very important but without this error will be better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2017 Pentaho Corporation. All Rights Reserved.