Hitachi Vantara Pentaho Community Forums
Results 1 to 12 of 12

Thread: CITRUS M3 PRPT report visibility

  1. #1

    Default CITRUS M3 PRPT report visibility

    BI version : CITRUS M3

    I have a unified file report (the new type) which has a number of parameters.
    I also have an xaction file that uses that report and everything is OK.

    What I would like would be a means to 'hide' the PRPT report and just allow access to the underlying report using the xaction file. I have tried to suppress the PRPT report using permissions which means that report is not visible, but this also stops the xaction file from working - as I can reasonably argue is correct.

    Suggestions welcome

    Daniel
    ------------
    Daniel Goodwin

  2. #2

    Default

    hello daniel,

    Im having trouble what you tried to do. could you explain how you were able to publish the report on the server or how did you get to integrate the prpt file with the design studio?
    Simplicity never killed anybody!

  3. #3

    Default

    Ok, I have CITRUS M3 server install ok and I publish to that from the report designer (CITRUS M7). All that works OK as normal.

    On the xaction file, as none is created during publish to server, I created one manually and used Report designer to manipulate it - In the CITRUS M3 install there is a sample xaction file in the bi-developers\reporting\unified-file-format folder (quadrant-xaction.xaction) - basically I just 'changed' that one and it worked fine (copying it manually into the report folder on the bi-server).

    Now I have not yet got the permissions part to work whereby the PRPT part is hidden and user just sees xaction file and for now I'm still using the V3.0 stable server in production as the new report/server aint stable enough to use.
    ------------
    Daniel Goodwin

  4. #4

    Default

    Did you find any way to hide the prpt file?

    I think we got the same problem. We just want to see the xaction only, not the prpt-file

  5. #5
    Join Date
    Dec 2005
    Posts
    531

    Default

    Here is what you can do:

    - Put your prpt file in a new subfolde folder. Don't forget to add an index.xml, too.
    - Then you need to hide the folder from your user but let him have execute rights on the report.
    - Don't forget to change the xaction to point to the new location or the prpt.

    Now the user can't see the prpt-file, since the folder is not visible, but he is still able to execute the report via the xaction.
    Last edited by ingo.klose; 09-11-2009 at 07:50 AM.

  6. #6
    Join Date
    Dec 2009
    Posts
    28

    Default

    Hi,
    This solution is only for hidding the report, but we can access this report directly if we know its path.

    Aziz

  7. #7
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    there's not a lot you can do about that, although i could imagine a workaround.

    you could setup a prompt on the prpt, which says "dont run me directly" and prompts for a "password". the report wont run unless they enter the correct value for the parameter.

    then just hard code the "password" as a parameter in the xaction.

    Hack; Yes. but if you really want to stop them running prpt direct it may be your only option.

    I think hiding prpt's is raised as a jira,to get it to handle it better, but can't confirm 100%, this sounds like a wider issue though, so worth raising.

  8. #8
    Join Date
    Dec 2009
    Posts
    28

    Default

    thanks, a very usefull trick

  9. #9
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    ingo - how exactly do you hide the prpt?

    I dont see a permission for that??

  10. #10
    Join Date
    Dec 2005
    Posts
    531

    Default

    Don't give any permission to the user/role on that folder, that's what I meant by hide.

  11. #11
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    But if you do that, then you get an error when the xaction tries to access the prpt - it gets the equivalent of a file not found error...

  12. #12
    Join Date
    Dec 2009
    Posts
    28

    Default

    You can only hide the folder not .prpt, as said by ingo.klose bellow you have to change index.xml under this folder by changing the attribut
    <visible>true</visible>
    by
    <visible>false</visible>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.