Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: Problem with using 3.1.x and 3.2 with the same user

  1. #1

    Default Problem with using 3.1.x and 3.2 with the same user

    Hi,

    I am still using Kettle 3.1.4 and I looked into 3.2 to find an error for a customer. When I switched back to 3.1.4 I could not find any of my transformations and steps in my repository. The only thing I could see were my directories. This might have happened because I had both programs open at the same time, maybe it always happens. The solution that I found was to delete all files in .kettle directory except for kettle.properties. I had to reenter my repository connection, but afterwards everything was back to normal. I know that the repositories are different, but something must also be different about the files. So, if you also run into this problem, this seems to be the solution.

    Bye

    Holger

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    It *should* all be fine. Repositories.xml format wasn't changed in years ever since repositories were conceived since the PDI 1.2 days.
    So perhaps it's a locking issue somewhere/somehow. I know Windows can be nasty with exclusive file locks and all.

    Just don't mess with PDI 4.0 and repositories ... yet. :-)

  3. #3

    Default

    I was the sole user on both repositories at the time. So, I do not think it was a locking problem. I also retried accessing a number of times. Only when I erased those files, I was able to access my transformations and jobs again. Yes, the xml file format still looks the same.
    I got into the repositores and saw the directory structure, just no transformations and jobs.
    Last edited by Hymmen; 06-29-2009 at 05:29 AM.

  4. #4
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Well, in general it's obviously a very bad idea to mix versions when dealing with central repositories. We even give an upgrade warning for the repository. Perhaps we should do this as well for the software.

  5. #5

    Default

    I used the correct versions of the program to access the connected repository. Kettle 3.1.4 for an 3.1.x repository and Kettle 3.2 for an 3.2 repository.

  6. #6

    Default

    The problem also remains, when I open 3.2.0, close it and then open 3.1.4.

  7. #7
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Again, I don't recomment mixing versions, certainly not with the upcomming 4.0 release.
    I guess I would recommend setting a different KETTLE_HOME for each version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.