Hola a todos,

Les comento toy realizando un cubo con workbench-3.0.3.11016 donde creo roles poq esta herramienta lo permite, quedando el archivo xml de la siguiente manera la parte de roles:

<Role name="ceo">
<SchemaGrant access="none">
<CubeGrant cube="SIIRH_Servidores" access="none">
<DimensionGrant dimension="TIEMPO" access="all">
</DimensionGrant>
<DimensionGrant dimension="UBI_GEOGRAFICAS" access="none">
</DimensionGrant>
<DimensionGrant dimension="TIP_MOVIMIENTOS" access="all">
</DimensionGrant>
<DimensionGrant dimension="REGIMEN" access="all">
</DimensionGrant>
<HierarchyGrant hierarchy="UBI_GEOGRAFICAS" rollupPolicy="partial" topLevel="[UBI_GEOGRAFICAS].[REGION]" access="custom">
<MemberGrant member="[UBI_GEOGRAFICAS].[ORIENTE]" access="none">
</MemberGrant>
<MemberGrant member="[UBI_GEOGRAFICAS].[COSTA]" access="none">
</MemberGrant>
<MemberGrant member="[UBI_GEOGRAFICAS].[INSULAR]" access="none">
</MemberGrant>
<MemberGrant member="[UBI_GEOGRAFICAS].[SIERRA]" access="all">
</MemberGrant>
</HierarchyGrant>
</CubeGrant>
</SchemaGrant>
</Role>

y el xaction lo tengo de la siguiente forma:

<?xml version="1.0" encoding="UTF-8"?>
<action-sequence>
<name>analysis_default.xaction</name>
<title>Ejemplo de análisis con roles</title>
<version>1</version>
<logging-level>DEBUG</logging-level>
<documentation>
<author>EEIY</author>
<help/>
<result-type>vista usando roles</result-type>
<description>vista usando roles</description>
<icon>analysis_default.png</icon>
</documentation>
<inputs>
<mode type="string">
<default-value/>
<sources>
<request>mode</request>
</sources>
</mode>
<roles_from_pentaho_security type="string-list">
<sources>
<security>principalRoles</security>
</sources>
</roles_from_pentaho_security>
<role type="string">
<sources>
<request>role</request>
</sources>
<default-value/>
</role>
</inputs>
<outputs>
<model type="string"/>
<connection type="string"/>
<mdx type="string"/>
<options type="list"/>
<title type="string"/>
<url type="string">
<destinations>
<response>redirect</response>
</destinations>
</url>
<role type="string"/>
</outputs>
<resources/>

<actions>
<action-definition>
<component-name>SecureFilterComponent</component-name>
<action-type>Prompt/Secure Filter</action-type>
<action-inputs>
<role type="string"/>
<roles_from_pentaho_security type="string-list"/>
</action-inputs>
<component-definition>
<selections>
<role style="select">
<title>seleccione el rol</title>
<filter>roles_from_pentaho_security</filter>
</role>
</selections>
</component-definition>
</action-definition>

<action-definition>
<component-name>PivotViewComponent</component-name>
<action-type>Analysis View</action-type>
<action-inputs>
<mode type="string"/>
<role type="string"/>
</action-inputs>
<action-outputs>
<model type="string"/>
<connection type="string"/>
<mdx type="string"/>
<options type="list"/>
<title type="string"/>
<url type="string"/>
</action-outputs>
<component-definition>
<title>Analysis View</title>
<viewer>Pivot</viewer>
<options>
<personal/>
<cube-nav/>
<mdx-edit/>
<sort-conf/>
<spacer/>
<level-style/>
<hide-spans/>
<properties/>
<non-empty/>
<swap-axes/>
<spacer/>
<drill-member/>
<drill-position/>
<drill-replace/>
<drill-thru/>
<spacer/>
<chart/>
<chart-conf/>
<spacer/>
<print-conf/>
<print-pdf/>
<spacer/>
<excel/>
</options>
<jndi><![CDATA[postgresql_senres]]></jndi>
<model><![CDATA[solution:/samples/analysis/SIIRH_Servidores.mondrian.xml]]></model>
<query><![CDATA[default]]></query>
</component-definition>
<action-name>Pivot View</action-name>
<logging-level>DEBUG</logging-level>
</action-definition>
</actions>
</action-sequence>

PERO AL MOMENTO Q PUBLICO EL CUBO ME SALE EN BLANCO Y EL LOG DE PENTAHO ME ARROJA EL SIGUIENTE ERROR:

10:19:27,176 ERROR [STDERR] Caused by: com.tonbeller.jpivot.olap.model.OlapException: Mondrian Error:MDX cube 'SIIRH_Servidores' not found

Espero contar con su ayuda desde ya mil gracias.

eeiy