Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: setting JVM memory

  1. #1

    Question setting JVM memory

    Hi

    Anyone out there that might know why executing spoon with OPT=-Xmx1024m works fine but using OPT=-Xmx2048m tells me that the JVM cannot start?

    It's a Win 2003 Server (64-bit) SP2 running the 32-bit jre. It has 32GB RAM of which 26GB is currently used by MS SQL 2008.

    Thanks
    Paul
    Last edited by PollieXmas; 07-08-2009 at 09:03 AM.

  2. #2

    Default

    Quote Originally Posted by PollieXmas View Post
    Hi

    Anyone out there that might know why executing spoon with OPT=-Xmx1024m works fine but using OPT=-Xmx2048m tells me that the JVM cannot start?

    It's a Win 2003 Server (64-bit) SP2 running the 32-bit jre. It has 32GB RAM of which 26GB is currently used by MS SQL 2008.

    Thanks
    Paul
    If I recall my CS classes, 64-bit would give you a lot more memory to address and therefore use.

    So why are you running a 32-bit JRE on a 64-bit OS? Our sysadmins have setup 64-bit JREs on our Linux servers (64-bit) and we never ran out of memory.
    Pentaho Data Integration CE 5.3.0.x
    JDK 1.7
    OS X Yosemite version 10.10.x
    MySQL 5.5.37
    Amazon Redshift
    Pacific Standard Time

  3. #3
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    For discussion, see here: http://www-01.ibm.com/support/docvie...id=swg21249894
    Specifically: "there is 1536 MB left that can be used for the java heap"

    I know it's not really accurate for your environment, but I would expect that the 32bit JRE is checking that max.

    Try either setting to 1536 or using a 64bit JRE.

  4. #4

    Thumbs up Thanks for the feedback

    Hi,

    Thanks for the feedback. I will investigate your suggestions.

    When I first started out I could not get PDI to work on the 64-bit machine, but was still very green then. I'm now a little more comfortable with how to perform fault find in the spoon.bat file and will give it another try once I get some breathing space.

    It was fine up to now with only 512m but I want to use "copy rows to result" 600k-900k rows which needs a little more than 512m ;-)

    Regards
    Paul

  5. #5

    Thumbs up Update

    Thanks guys,

    Got this working. My JVM is now running with 2G of RAM.

    Regards
    Paul

    Ps. For other newbies like me. You have to over-write the 32-bit file swt.jar with the 64-bit version of the file. The 64-bit version can be found here. http://wiki.pentaho.org:8080/browse/PDI-1881

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.