Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Hide the main tool bar

  1. #1

    Default Hide the main tool bar

    Hi

    I wanted to Hide the main tool bar on the User Console Login.

    I was able to hide it partially. I just wanted to keep the "Open" button on that tool bar and nothing else.

    But somehow the Dashboard button is still being displayed (please see the attachment). I am not sure from where it is getting displayed but i wanted to get rid of it.

    I have made changes in the following file to hide other button from the tool bar

    tomcat\webapps\pentaho\mantle\xul\main_toolbar

    <toolbar id="mainToolbar">
    <toolbarspacer width="10"/>
    <toolbarbutton id="openButton" image="mantle/images/open_32.png" onclick="mainToolbarHandler.openClicked()" tooltiptext="${openEllipsis}"/>
    <toolbarspacer width="20" pen:visible="false"/>
    <toolbarbutton id="newAdhocButton" image="mantle/images/new_report_32.png" onclick="mainToolbarHandler.newAdhocClicked()" tooltiptext="${newAdhocReportEllipsis}" pen:visible="false"/>
    <toolbarbutton id="newAnalysisButton" image="mantle/images/new_analysis_32.png" disabledimage="mantle/images/new_analysis_32_disabled.png" onclick="mainToolbarHandler.newAnalysisClicked()" tooltiptext="${newAnalysisViewEllipsis}" pen:visible="false"/>
    <toolbarspacer width="20" pen:visible="false"/>
    <toolbarbutton id="editContentButton" image="mantle/images/editContent_32.png" disabledimage="mantle/images/editContent_32_disabled.png" onclick="mainToolbarHandler.editContentClicked()" tooltiptext="${editContent}" disabled="true" type="toggle" pen:visible="false"/>
    <toolbarspacer id="editButtonSpacer" width="20" pen:visible="false"/>
    <toolbarbutton id="saveButton" image="mantle/images/save_32.png" disabledimage="mantle/images/save_32_disabled.png" onclick="mainToolbarHandler.saveClicked()" tooltiptext="${save}" disabled="true" pen:visible="false"/>
    <toolbarbutton id="saveAsButton" image="mantle/images/saveAs_32.png" disabledimage="mantle/images/saveAs_32_disabled.png" onclick="mainToolbarHandler.saveAsClicked()" tooltiptext="${saveAs}" disabled="true" pen:visible="false"/>
    <toolbarspacer width="20" pen:visible="false"/>
    <toolbarbutton id="printButton" image="mantle/images/print_32.png" disabledimage="mantle/images/print_32_disabled.png" onclick="mainToolbarHandler.printClicked()" tooltiptext="${print}" disabled="true" pen:visible="false"/>
    <toolbarspacer width="20" pen:visible="false"/>
    <toolbarbutton id="workspaceButton" image="mantle/images/workspace_32.png" type="toggle" onclick="mainToolbarHandler.workspaceClicked()" tooltiptext="${workspace}" pen:visible="false"/>
    <toolbarbutton id="showBrowserButton" image="mantle/images/browser_show_32.png" downimage="mantle/images/browser_hide_32.png" type="toggle" onclick="mainToolbarHandler.showBrowserClicked()" tooltiptext="${toggleSolutionBrowser}" pen:visible="false"/>
    </toolbar>

    I am using 3.0.1-GA.

    Please let me know if anybody has any solution on it.
    Attached Images Attached Images  

  2. #2

    Default

    Hi vishaltalentbeat,

    I was also facing the same problem which you described. Did you get any solution to this? How did you manage to hide the remaining buttons on the toolbar?

    sorry for my questions but i need help in this regard.

    Thank you in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.