Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Problem: connect to my mssql database with kettle

  1. #1
    Join Date
    Jun 2009
    Posts
    5

    Exclamation Problem: connect to my mssql database with kettle

    I am trying to connect to my mssql database with kettle.
    I put all the items correct, check the connection and it is ok, I can even explore de DB.
    The problem comes when I try to open acces kettle transformation, where it appears a message: (i translate from spanish...)

    The repository version is -1. -1
    This Kettle edition requires it to be at least version 4.3 and as such an upgrade is required.

    To upgrade, export de repository to XML for backup purposes.
    Then select the 'edit' button followed by the 'create or upgrade' buton.


    I do so, execute the mysql sentence and appears:

    Couldn't execute SQL: INSERT INTO R_VERSION(ID_VERSION, MAJOR_VERSION, MINOR_VERSION, UPGRADE_DATE, IS_UPGRADE) VALUES (3,3,2,'2009/07/15 16:46:15.631','Y')

    The convertion of type char and datatime produced a datatime value out of time.


    Can anybody help me with this problem?

    Best regards,

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    What kind of version of Kettle are you using?

  3. #3
    Join Date
    Jun 2009
    Posts
    5

    Default

    Spoon 3.2.0

    thank you,

  4. #4
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    No idea, sorry. Looks like there is no repository on the supplied connection.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.